<font size=2 face="sans-serif">Hi Peter,</font>
<br>
<br><font size=2 face="sans-serif">I'm glad I'm not the only one who has
run into this issue. I am considering reverting a couple of patches to
move back to having the recipe directly point out the dts in the kernel
sources instead of relying on the kernel's do_shared_workdir task. I haven't
tried building everything with just meta-xilinx, but I did quickly try
to remove meta-xilinx-tools from my bblayers and build the device-tree
recipe, resulting in this error --</font>
<br>
<br><font size=2 face="sans-serif">ERROR: ParseError at /work/MPSoC/customization/meta-ultra/recipes-bsp/bootbin/xilinx-bootbin.bb:7:
Could not inherit file classes/xsct-tc.bbclass</font>
<br>
<br><font size=2 face="sans-serif">For the moment I'll probably either
revert the relevant commits as I mentioned or duplicate the device tree
sources into my local/custom meta-layer as you mention. I would definitely
like to know how to resolve this issue though as intended for my own education
on the xilinx recipes and yocto build system.</font>
<br>
<br><font size=2 face="sans-serif">Thanks,</font>
<br><font size=2 face="sans-serif">Holden</font>
<br>
<br>
<br>
<br>
<br>
<br><font size=1 color=#5f5f5f face="sans-serif">From:      
 </font><font size=1 face="sans-serif">Peter Smith <salerio@gmail.com></font>
<br><font size=1 color=#5f5f5f face="sans-serif">To:      
 </font><font size=1 face="sans-serif">Holden.Sandlar@ultra-fei.com</font>
<br><font size=1 color=#5f5f5f face="sans-serif">Cc:      
 </font><font size=1 face="sans-serif">meta-xilinx@yoctoproject.org</font>
<br><font size=1 color=#5f5f5f face="sans-serif">Date:      
 </font><font size=1 face="sans-serif">10/05/2017 03:30 AM</font>
<br><font size=1 color=#5f5f5f face="sans-serif">Subject:    
   </font><font size=1 face="sans-serif">Re: [meta-xilinx]
meta-xilinx device-tree recipe on master / yocto pyro</font>
<br>
<hr noshade>
<br>
<br>
<br><font size=2 face="Verdana">​​</font>
<br><font size=2 face="Verdana">I had the exact same problem yesterday.
I have yet to look into it, but what you are suggesting seems to be the
case for me too.</font>
<br>
<br><font size=2 face="Verdana">Out of interest have you tried building
the zcu102-zynqmp machine with just the meta-xilinx (and poky)
layers to see if that works as expected? In my case.</font>
<br>
<br><font size=2 face="Verdana">I have a layer on top of these two where
I have a customised .dts file and I define KERNEL_DEVICETREE in a recipes-kernel/linux linux-xlnx_%.bbappend file.
To get around the problem I temporarily duplicated by device tree file.</font>
<br>
<br><font size=3>Best Regards</font>
<br><font size=3>Peter</font>
<br>
<br><font size=3>On 4 October 2017 at 22:34, <</font><a href="mailto:Holden.Sandlar@ultra-fei.com" target=_blank><font size=3 color=blue><u>Holden.Sandlar@ultra-fei.com</u></font></a><font size=3>>
wrote:</font>
<br><font size=2 face="sans-serif">Hi all,</font><font size=3> <br>
</font><font size=2 face="sans-serif"><br>
I'm hoping this is a quick and easy issue someone already knows the answer
to. I'm working with a ZCU102, using meta-petalinux, meta-xilinx, meta-xilinx-tools
and bitbake/poky 1.34.0 -- both meta-xilinx and meta-xilinx-tools on the
master branch and am having an issue with the meta-xilinx device-tree recipe.
Just for quick and easy reference, the device-tree recipe is here: </font><a href="https://github.com/Xilinx/meta-xilinx/blob/master/recipes-bsp/device-tree/device-tree.bb" target=_blank><font size=2 color=blue face="sans-serif"><u>https://github.com/Xilinx/meta-xilinx/blob/master/recipes-bsp/device-tree/device-tree.bb</u></font></a><font size=3>
<br>
</font><font size=2 face="sans-serif"><br>
The issue that I'm running into is that when I run "bitbake device-tree"
I get an error that there are no dts files in the device-tree/1.0-r0 directory.
Full error shown below:</font><font size=3> <br>
</font><font size=2 face="sans-serif"><br>
ERROR: device-tree-1.0-r0 do_compile: Function failed: do_compile (log
file is located at /work/MPSoC/yocto_2017.2/build/tmp/work/zcu102_zynqmp-xilinx-linux/device-tree/1.0-r0/temp/log.do_compile.15884)</font><font size=3>
</font><font size=2 face="sans-serif"><br>
ERROR: Logfile of failure stored in: /work/MPSoC/yocto_2017.2/build/tmp/work/zcu102_zynqmp-xilinx-linux/device-tree/1.0-r0/temp/log.do_compile.15884</font><font size=3>
</font><font size=2 face="sans-serif"><br>
Log data follows:</font><font size=3> </font><font size=2 face="sans-serif"><br>
| DEBUG: Executing shell function do_compile</font><font size=3> </font><font size=2 face="sans-serif"><br>
| /work/MPSoC/yocto_2017.2/build/tmp/work/zcu102_zynqmp-xilinx-linux/device-tree/1.0-r0</font><font size=3>
</font><font size=2 face="sans-serif"><br>
| gcc: error: /work/MPSoC/yocto_2017.2/build/tmp/work/zcu102_zynqmp-xilinx-linux/device-tree/1.0-r0/*.dts:
No such file or directory</font><font size=3> </font><font size=2 face="sans-serif"><br>
| gcc: warning: ‘-x assembler-with-cpp’ after last input file has no
effect</font><font size=3> </font><font size=2 face="sans-serif"><br>
| gcc: fatal error: no input files</font><font size=3> </font><font size=2 face="sans-serif"><br>
| compilation terminated.</font><font size=3> </font><font size=2 face="sans-serif"><br>
| WARNING: /work/MPSoC/yocto_2017.2/build/tmp/work/zcu102_zynqmp-xilinx-linux/device-tree/1.0-r0/temp/run.do_compile.15884:1
exit 4 from 'gcc -E -nostdinc -Ulinux -x assembler-with-cpp -I/work/MPSoC/yocto_2017.2/build/tmp/work/zcu102_zynqmp-xilinx-linux/device-tree/1.0-r0
-I/work/MPSoC/yocto_2017.2/build/tmp/work-shared/zcu102-zynqmp/kernel-source/arch/arm64/boot/dts
-I/work/MPSoC/yocto_2017.2/build/tmp/work-shared/zcu102-zynqmp/kernel-source/arch/arm64/boot/dts/include
-I/work/MPSoC/yocto_2017.2/build/tmp/work-shared/zcu102-zynqmp/kernel-source/arch/arm64/boot/dts/xilinx
-o `basename ${DTS_FILE}`.pp ${DTS_FILE}'</font><font size=3> </font><font size=2 face="sans-serif"><br>
| ERROR: Function failed: do_compile (log file is located at /work/MPSoC/yocto_2017.2/build/tmp/work/zcu102_zynqmp-xilinx-linux/device-tree/1.0-r0/temp/log.do_compile.15884)</font><font size=3>
</font><font size=2 face="sans-serif"><br>
ERROR: Task (/work/MPSoC/yocto_2017.2/sources/core/../meta-xilinx/recipes-bsp/device-tree/device-tree.bb:do_compile)
failed with exit code '1'</font><font size=3> </font><font size=2 face="sans-serif"><br>
NOTE: Tasks Summary: Attempted 534 tasks of which 464 didn't need to be
rerun and 1 failed.</font><font size=3> <br>
</font><font size=2 face="sans-serif"><br>
Summary: 1 task failed:</font><font size=3> </font><font size=2 face="sans-serif"><br>
  /work/MPSoC/yocto_2017.2/sources/core/../meta-xilinx/recipes-bsp/device-tree/device-tree.bb:do_compile</font><font size=3>
</font><font size=2 face="sans-serif"><br>
Summary: There were 5 WARNING messages shown.</font><font size=3> </font><font size=2 face="sans-serif"><br>
Summary: There was 1 ERROR message shown, returning a non-zero exit code.</font><font size=3>
<br>
</font><font size=2 face="sans-serif"><br>
After reviewing the history on this recipe, it appears the recipe was restructured
months ago to "Improve, clean up and remove MACHINE_DEVICETREE".
Based on this commit, it appears the intent was to use the dts/dtsi files
within the kernel sources as a base for generating a device tree. There
was a line added to ensure that "virtual/kernel:do_shared_workdir"
is run prior to the device-tree recipe. My assumption is that the kernel
recipe do_shared_workdir task is supposed to copy the selected machine's
dts files into the shared workdir so they can be used by this device-tree
recipe. However, this does not seem to happen in my case --</font><font size=3>
<br>
</font><font size=2 face="sans-serif"><br>
/work/MPSoC/yocto_2017.2/build/tmp/work-shared/zcu102-zynqmp/kernel-source$
ls</font><font size=3> </font><font size=2 face="sans-serif"><br>
arch   COPYING  Documentation  fs       ipc
     kernel       Makefile  README  
       scripts   tools</font><font size=3> </font><font size=2 face="sans-serif"><br>
block  CREDITS  drivers        include  Kbuild
  lib          mm        REPORTING-BUGS
 security  usr</font><font size=3> </font><font size=2 face="sans-serif"><br>
certs  crypto   firmware       init    
Kconfig  MAINTAINERS  net       samples  
      sound     virt</font><font size=3> <br>
</font><font size=2 face="sans-serif"><br>
Additionally, the device-tree recipe loops over any *.dts files in the
${S} directory, which is mapped to ${WORKDIR} in this recipe (</font><a href="https://github.com/Xilinx/meta-xilinx/blob/master/recipes-bsp/device-tree/device-tree.bb#L51" target=_blank><font size=2 color=blue face="sans-serif"><u>https://github.com/Xilinx/meta-xilinx/blob/master/recipes-bsp/device-tree/device-tree.bb#L51</u></font></a><font size=2 face="sans-serif">).
This loop will effectively do an ls in the build/tmp/work/zcu102_zynqmp-xilinx-linux/device-tree/1.0-r0
directory to check for any *.dts files. This directory definitely does
not contain any dts files.</font><font size=3> <br>
</font><font size=2 face="sans-serif"><br>
I'm guessing I'm missing something small/simple here. Can anyone provide
any guidance?</font><font size=3> <br>
</font><font size=2 face="sans-serif"><br>
Thanks,</font><font size=3> </font><font size=2 face="sans-serif"><br>
Holden </font><font size=3><br>
NOTICE: The contents of this document are proprietary to Ultra Electronics
Flightline Systems and the noted recipient/s and shall not be disclosed,
disseminated, copied, in whole or in part or used except for the purposes
expressly authorized in writing by Ultra Electronics Flightline Systems.
This document may contain technical data, which may be restricted for export
under the International Traffic in Arms Regulations (ITAR) or the Export
Administration Regulations (EAR). Violations of these export laws may be
subject to fines and penalties under the Arms Export Control Act (22 U.S.C.
2778)   ­­  <br>
--<br>
_______________________________________________<br>
meta-xilinx mailing list</font><font size=3 color=blue><u><br>
</u></font><a href="mailto:meta-xilinx@yoctoproject.org"><font size=3 color=blue><u>meta-xilinx@yoctoproject.org</u></font></a><font size=3 color=blue><u><br>
</u></font><a href="https://lists.yoctoproject.org/listinfo/meta-xilinx" target=_blank><font size=3 color=blue><u>https://lists.yoctoproject.org/listinfo/meta-xilinx</u></font></a><font size=3><br>
</font>
<br>
<br>
<br>
<br>NOTICE: The contents of this document are proprietary to Ultra Electronics Flightline Systems and the noted recipient/s and shall not be disclosed, disseminated, copied, in whole or in part or used except for the purposes expressly authorized in writing by Ultra Electronics Flightline Systems.  This document may contain technical data, which may be restricted for export under the International Traffic in Arms Regulations (ITAR) or the Export Administration Regulations (EAR).  Violations of these export laws may be subject to fines and penalties under the Arms Export Control Act (22 U.S.C. 2778)
  ­­