[meta-xilinx] Building a Xen image on Yocto for ZCU102 board

Doug Goldstein cardoe at cardoe.com
Tue Mar 7 07:10:45 PST 2017

On 3/7/17 3:41 AM, Pello Heriz wrote:
> Hi all,
> as you know, I'm trying to build a Xen image using Yocto master branch
> for ZCU102 board.
> I have been experimenting some errors during the last days when I have
> tried to execute bitbake xen-image-minimal command.
> Some of you have told me to change to a stable branch in order to don't
> have errors, but some weeks ago I tried to build a core-image-minimal
> for ZCU102 using Morty branch and I couldn't. I think that this branch
> has not enough support in order to build images for this (ZCU102)
> target. Anyway if this information is not correct, I need to test the
> image using QEMU emulator, and this also would't be possible with Morty
> for the ZCU102 board case.

I can build for the zcu102 for krogoth and morty so support is certainly
there. I couldn't guess what issue you ran into however.

> In the other hand, when I try to execute xen-image-minimal using master
> branch, I experimented this error:
> Txertatutako irudia 1

A screenshot is really not helpful. You've also snipped out any of the
context so its impossible to say why it failed.

> As you can see, it's an error related to compilation. I have read that
> the error can be due to the GCC compiler version in the next
> link: https://lists.yoctoproject.org/pipermail/meta-virtualization/2015-December/001589.html
> Could this be the problem? If yes, how can I solve it? in which file do
> I need to change the compiler version I want to use?

No way of knowing. Its likely not the issue. The issue is most likely
related to the fact that Yocto master uses a newer version of GCC than
is supported by the Xen 4.8 release. There's probably some new warnings
added that are causing the issue but again there's no context in your
bug report so its impossible to tell.

> On the other side, do I need to include meta-petalinux layer in my
> project in order to use Xen? That's what I have read in the next link:
> http://www.wiki.xilinx.com/Xen+Hypervisor+through+Yocto+Flow
> This link also says that the used machine can be qemuzynqmp and that's
> not correct. In my case, I'm trying to build the image using
> zcu102-zynqmp machine.

In one of your previous emails I mentioned that I am able to build for
the qemu Zynq target without meta-petalinux so that should not be
necessary. PetaLinux is just Xilinx's flavor of Yocto and includes a lot
of software packages they promote.

> Anyway, if I include meta-petalinux layer on my project, I got an error
> related to qt5. I have tried to include meta-qt5 layer too, but I got
> the next error:
> Txertatutako irudia 2

Once again this screenshot snips out any of the context about the issue
so its impossible to tell. I can tell you from the warnings about using
deprecated things that this layer is likely not meant to be built with
Yocto master and will likely fail.

> Other thing that I have read that I need to add to my project in order
> to configure the kernel for using Xen, has been to append in the
> local.conf file the DISTRO_FEATURES_append = " xen". I also have done
> this, but the bitbake result was the same as first reported image where
> it says that has occurred a compilation error.
> So can anybody answer this questions please?

I'm not really sure what the above means.

> Just for adding some more information, the layers that I have add in my
> bblayers file are the next:
> BBLAYERS ?= " \
>   /opt/yocto_GE/yocto_master_v2/poky/meta \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-poky \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-yocto-bsp \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-xilinx \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-virtualization \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-openembedded/meta-oe \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-openembedded/meta-networking \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-openembedded/meta-filesystems \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-openembedded/meta-python \
>   /opt/yocto_GE/yocto_master_v2/poky/oe-meta-go \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-selinux \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-petalinux \
>   /opt/yocto_GE/yocto_master_v2/poky/meta-qt5 \
>   " 

If you're just trying to build a basic Xen image you've got a lot of
unnecessary layers which can certainly contribute to problems.

Doug Goldstein

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 959 bytes
Desc: OpenPGP digital signature
URL: <http://lists.yoctoproject.org/pipermail/meta-xilinx/attachments/20170307/e7571cd8/attachment.pgp>

More information about the meta-xilinx mailing list