[meta-xilinx] Fwd: Building a Xen image on Yocto for ZCU102 board

Pello Heriz pello.heriz at alumni.mondragon.edu
Tue Mar 7 01:46:51 PST 2017

---------- Forwarded message ----------
From: Pello Heriz <pello.heriz at alumni.mondragon.edu>
Date: 2017-03-07 10:41 GMT+01:00
Subject: Building a Xen image on Yocto for ZCU102 board
To: meta-xilinx at yoctoproject.org, meta-xilinx-request at yoctoproject.org,
meta-virtualization at yoctoproject.org, cardoe at cardoe.com, matha at xilinx.com,
Alistair Francis <alistair23 at gmail.com>

Hi all,

as you know, I'm trying to build a Xen image using Yocto master branch for
ZCU102 board.

I have been experimenting some errors during the last days when I have
tried to execute bitbake xen-image-minimal command.

Some of you have told me to change to a stable branch in order to don't
have errors, but some weeks ago I tried to build a core-image-minimal for
ZCU102 using Morty branch and I couldn't. I think that this branch has not
enough support in order to build images for this (ZCU102) target. Anyway if
this information is not correct, I need to test the image using QEMU
emulator, and this also would't be possible with Morty for the ZCU102 board

In the other hand, when I try to execute xen-image-minimal using master
branch, I experimented this error:

[image: Txertatutako irudia 1]

As you can see, it's an error related to compilation. I have read that the
error can be due to the GCC compiler version in the next link:
Could this be the problem? If yes, how can I solve it? in which file do I
need to change the compiler version I want to use?

On the other side, do I need to include meta-petalinux layer in my project
in order to use Xen? That's what I have read in the next link:
This link also says that the used machine can be qemuzynqmp and that's not
correct. In my case, I'm trying to build the image using zcu102-zynqmp
Anyway, if I include meta-petalinux layer on my project, I got an error
related to qt5. I have tried to include meta-qt5 layer too, but I got the
next error:

[image: Txertatutako irudia 2]

Other thing that I have read that I need to add to my project in order to
configure the kernel for using Xen, has been to append in the local.conf
file the DISTRO_FEATURES_append = " xen". I also have done this, but the
bitbake result was the same as first reported image where it says that has
occurred a compilation error.

So can anybody answer this questions please?

Just for adding some more information, the layers that I have add in my
bblayers file are the next:

  /opt/yocto_GE/yocto_master_v2/poky/meta \
  /opt/yocto_GE/yocto_master_v2/poky/meta-poky \
  /opt/yocto_GE/yocto_master_v2/poky/meta-yocto-bsp \
  /opt/yocto_GE/yocto_master_v2/poky/meta-xilinx \
  /opt/yocto_GE/yocto_master_v2/poky/meta-virtualization \
  /opt/yocto_GE/yocto_master_v2/poky/meta-openembedded/meta-oe \
  /opt/yocto_GE/yocto_master_v2/poky/meta-openembedded/meta-networking \
  /opt/yocto_GE/yocto_master_v2/poky/meta-openembedded/meta-filesystems \
  /opt/yocto_GE/yocto_master_v2/poky/meta-openembedded/meta-python \
  /opt/yocto_GE/yocto_master_v2/poky/oe-meta-go \
  /opt/yocto_GE/yocto_master_v2/poky/meta-selinux \
  /opt/yocto_GE/yocto_master_v2/poky/meta-petalinux \
  /opt/yocto_GE/yocto_master_v2/poky/meta-qt5 \

The last two are the ones that give different problems when I run bitbake.

I would appreciate any answer,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-xilinx/attachments/20170307/f604c33d/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image.png
Type: image/png
Size: 97738 bytes
Desc: not available
URL: <http://lists.yoctoproject.org/pipermail/meta-xilinx/attachments/20170307/f604c33d/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image.png
Type: image/png
Size: 266892 bytes
Desc: not available
URL: <http://lists.yoctoproject.org/pipermail/meta-xilinx/attachments/20170307/f604c33d/attachment-0001.png>

More information about the meta-xilinx mailing list