[meta-virtualization] python setuptools recipe

Bruce Ashfield bruce.ashfield at gmail.com
Fri Oct 2 05:46:38 PDT 2015

On Wed, Sep 30, 2015 at 3:03 PM, Edward Wingate <edwingate8 at gmail.com> wrote:
> On Wed, Sep 30, 2015 at 11:10 AM, Edward Wingate <edwingate8 at gmail.com> wrote:
>> I don't know what could be different about gevent-socketio.
> The setup.py for gevent-socketio has this line:
> setup_requires=('versiontools >= 1.7'),
> I manually removed that line and the recipe works now.  What should I
> do for permanent solution?  Create a patch?  Or how can I make it work
> even with this setup_requires?

Have you solved this yet ? I've never run into this myself, but maybe my
reply will jog the memory of someone that has.

Have you ruled out that the build is using a versiontools from your host
machine ? And that the versiontools is older than the 1.7 requirement ?

I don't see versiontools already in the layers, so if it is being picked up
from the host, then you very well could end up with this error.

I'd start by creating a versiontools 1.9.1 recipe, put it in the DEPENDS for
your recipe and see if everything is happy after that.


> --
> _______________________________________________
> meta-virtualization mailing list
> meta-virtualization at yoctoproject.org
> https://lists.yoctoproject.org/listinfo/meta-virtualization

"Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end"

More information about the meta-virtualization mailing list