[meta-virtualization] uwsgi fails to get packaged with bad RPATH

Adam Lee adam.yh.lee at gmail.com
Tue Sep 30 15:43:55 PDT 2014


Hello everyone, I am building uwsgi as a part of my image to run a web
application on my embedded board.

Ingredients including nginx builds fine, but I am getting the error
attached. I am building on Yocto Project 1.6.1 (current master).

Any insight will be greatly appreciated!

Adam

DEBUG: Executing python function sstate_task_prefunc
> DEBUG: Python function sstate_task_prefunc finished
> DEBUG: Executing python function do_package
> DEBUG: Executing python function package_get_auto_pr
> DEBUG: Python function package_get_auto_pr finished
> DEBUG: Executing python function perform_packagecopy
> DEBUG: Python function perform_packagecopy finished
> DEBUG: Executing python function split_and_strip_files
> DEBUG: runstrip: 'arm-poky-linux-gnueabi-strip' --remove-section=.comment
> --remove-section=.note
> '/media/Build/master/build/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/uwsgi/2.0.4+gitAUTOINC+7604c67018-r0/package/usr/bin/uwsgi'
> DEBUG: Python function split_and_strip_files finished
> DEBUG: Executing python function fixup_perms
> DEBUG: Python function fixup_perms finished
> DEBUG: Executing python function package_do_split_locales
> DEBUG: No locale files in this package
> DEBUG: Python function package_do_split_locales finished
> DEBUG: Executing python function populate_packages
> DEBUG: Python function populate_packages finished
> DEBUG: Executing python function do_package_qa
> NOTE: DO PACKAGE QA
> NOTE: Checking Package: uwsgi-staticdev
> NOTE: Checking Package: uwsgi-dev
> NOTE: Checking Package: uwsgi-dbg
> NOTE: arm-poky-linux-gnueabi-objdump -p
> /media/Build/master/build/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/uwsgi/2.0.4+gitAUTOINC+7604c67018-r0/packages-split/uwsgi-dbg/usr/bin/.debug/uwsgi
> NOTE: Checking Package: uwsgi-doc
> NOTE: Checking Package: uwsgi
> NOTE: arm-poky-linux-gnueabi-objdump -p
> /media/Build/master/build/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/uwsgi/2.0.4+gitAUTOINC+7604c67018-r0/packages-split/uwsgi/usr/bin/uwsgi
> ERROR: QA Issue: package uwsgi contains bad RPATH
> /media/Build/master/build/tmp/sysroots/duovero/usr/lib in file
> /media/Build/master/build/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/uwsgi/2.0.4+gitAUTOINC+7604c67018-r0/packages-split/uwsgi/usr/bin/uwsgi
> ERROR: QA run found fatal errors. Please consider fixing them.
> DEBUG: Python function do_package_qa finished
> DEBUG: Python function do_package finished
> ERROR: Function failed: do_package_qa
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-virtualization/attachments/20140930/4ea12185/attachment.html>


More information about the meta-virtualization mailing list