<div dir="ltr">Hello all,<div class="gmail_extra"><br></div><div class="gmail_extra">I'm trying to integrate meta-ti with Yocto/poky, since I need to add the 2.6.32 kernel for the beableboard image.</div><div class="gmail_extra">


<br></div><div class="gmail_extra">Can I please know how to download the correct version, i.e. i'm using danny-8.0, so for this, which version of the meta-ti and meta-oe should I download, and from where.. and also after downloading where should I put these folders (correct location for each)..</div>


<div class="gmail_extra"><br></div><div class="gmail_extra" style>I downloaded the danny branch of yocto, meta-ti, meta-oe and also the danny branch of openembedded-core as the dependency. Is it correct.?</div><div class="gmail_extra">

<br></div><div class="gmail_extra">Is there is weblink that I can follow..?</div><div class="gmail_extra"><br></div><div class="gmail_extra">For now, this is the error i'm getting..</div><div class="gmail_extra"><br>
</div>
<div class="gmail_extra"><div class="gmail_extra"><i><font color="#444444">danny-8.0/build$ bitbake -k core-image-minimal</font></i></div><div class="gmail_extra"><i><font color="#444444">Pseudo is not present but is required, building this first before the main build</font></i></div>

<div class="gmail_extra"><i><font color="#444444">WARNING: Host distribution "Ubuntu 12.04.2 LTS" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.</font></i></div>

<div class="gmail_extra"><i><font color="#444444">Loading cache: 100% |################################################################################################################################| ETA:  00:00:00</font></i></div>

<div class="gmail_extra"><i><font color="#444444">Loaded 22 entries from dependency cache.</font></i></div><div class="gmail_extra"><i><font color="#444444">ERROR: ExpansionError during parsing /home/suan/danny-try/danny-8.0/meta-ti/recipes-ti/local-power-manager/<a href="http://ti-local-power-manager_1.24.02.09.bb">ti-local-power-manager_1.24.02.09.bb</a>: Failure expanding variable FILESPATH, expression was ${@base_set_filespath([ "/home/suan/danny-try/danny-8.0/meta-ti/recipes-ti/local-power-manager/ti-local-power-manager-1_1_24_02_09-${MACHINE_KERNEL_PR}e", "/home/suan/danny-try/danny-8.0/meta-ti/recipes-ti/local-power-manager/ti-local-power-manager-1_24_02_09", "/home/suan/danny-try/danny-8.0/meta-ti/recipes-ti/local-power-manager/ti-local-power-manager", "/home/suan/danny-try/danny-8.0/meta-ti/recipes-ti/local-power-manager/ti-local-power-manager-1_24_02_09", "/home/suan/danny-try/danny-8.0/meta-ti/recipes-ti/local-power-manager/ti-local-power-manager", "/home/suan/danny-try/danny-8.0/meta-ti/recipes-ti/local-power-manager/files", "/home/suan/danny-try/danny-8.0/meta-ti/recipes-ti/local-power-manager" ], d)} which triggered exception SyntaxError: EOL while scanning string literal (FILESPATH, line 1)</font></i></div>

<div class="gmail_extra"><i><font color="#444444">ERROR: Command execution failed: Exited with 1</font></i></div><div class="gmail_extra"><i><font color="#444444"><br></font></i></div><div class="gmail_extra"><i><font color="#444444">Summary: There was 1 WARNING message shown.</font></i></div>

<div class="gmail_extra"><i><font color="#444444">Summary: There were 2 ERROR messages shown, returning a non-zero exit code.</font></i></div></div><div class="gmail_extra"><br></div><div class="gmail_extra" style>I hope this is not version mismatch problem..!! may be yes..!</div>

<div class="gmail_extra"><br clear="all"><div>---------------------------------<br>Sudhangathan BS<br>Ph:<a href="tel:%28%2B91%29%209731-905-205" value="+919731905205" target="_blank">(+91) 9731-905-205</a><br>
---------------------------------</div>
<br><br><div class="gmail_quote">On Wed, Jun 5, 2013 at 11:35 AM, Nicolas Dechesne <span dir="ltr"><<a href="mailto:nicolas.dechesne@linaro.org" target="_blank">nicolas.dechesne@linaro.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">



<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote"><div>On Wed, Jun 5, 2013 at 7:55 AM, Akshay Sahota <span dir="ltr"><<a href="mailto:akki.sahota@gmail.com" target="_blank">akki.sahota@gmail.com</a>></span> wrote:<br>





<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div><div><div><i><div>BBMASK ?= ".*/meta-ti/recipes-(misc|bsp/formfactor|graphics/mesa)/"<br>





</div>
#BBMASK = "meta-ti/recipes-misc meta-oe/recipes-graphics"<br>#BBMASK = "meta-oe/recipes-devtools"<br>#BBMASK = "meta-oe/recipes-graphics"<br>#<br># Parallelism Options</i>...<br><br><br></div>






and bblayers.conf<br><br><i>BBLAYERS ?= " \<br>  /home/asahota/poky-try/poky/meta \<br>  /home/asahota/poky-try/poky/meta-yocto \<br>  /home/asahota/poky-try/poky/meta-yocto-bsp \<br>  /home/asahota/poky-try/poky/meta-ti \<br>






  /home/asahota/poky-try/poky/meta-openembedded/meta-oe \<br>  "<br></i></div></div></blockquote><div><br></div></div><div class="gmail_extra">i suspect you are using wrong combination of branch/version, but you don't give what branch/version you are using, not cannot confirm.</div>



<div>

<div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div><div><i><br>BBLAYERS_NON_REMOVABLE ?= " \<br>





  /home/asahota/poky-try/poky/meta \<br>  /home/asahota/poky-try/poky/meta-yocto \<br>  "</i><br><br>
</div>and the output is :<br><i>$ bitbake -k core-image-minimal<br>Pseudo is not present but is required, building this first before the main build<br>WARNING: Host distribution "Ubuntu 12.04.2 LTS" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.<br>






ERROR: ParseError at /home/asahota/poky-try/poky/meta-openembedded/meta-oe/recipes-devtools/cloud9/<a href="http://cloud9_0.6.bb:11" target="_blank">cloud9_0.6.bb:11</a>: Could not inherit file classes/systemd.bbclass<br>





</i></div></blockquote><div> </div></div><div>systemd.bbclass was introduced in 'dylan' version of Yocto (aka 1.4). are you sure this is what you are using? to be it sounds like you are using Yocto/danny with meta-ti and meta-oe 'master' branch (or dylan branch). </div>



<div>

<div><br></div><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div><i>ERROR: Command execution failed: Exited with 1<br>






<br>Summary: There was 1 WARNING message shown.<br>Summary: There were 2 ERROR messages shown, returning a non-zero exit code.<br></i><br></div>What is the mistake, sounds too silly.!</blockquote></div></div><br></div><div class="gmail_extra">





<br></div></div>
<br>_______________________________________________<br>
yocto mailing list<br>
<a href="mailto:yocto@yoctoproject.org" target="_blank">yocto@yoctoproject.org</a><br>
<a href="https://lists.yoctoproject.org/listinfo/yocto" target="_blank">https://lists.yoctoproject.org/listinfo/yocto</a><br>
<br></blockquote></div><br></div></div>