[meta-ti] pandaboard/omap4 support

Richard Röjfors richard.rojfors at gmail.com
Wed Feb 12 06:15:38 PST 2014


On Wed, Feb 12, 2014 at 3:07 PM, Khem Raj <raj.khem at gmail.com> wrote:

>
> On Feb 12, 2014, at 6:03 AM, Richard Röjfors <richard.rojfors at gmail.com>
> wrote:
>
> On Wed, Feb 12, 2014 at 2:52 PM, Khem Raj <raj.khem at gmail.com> wrote:
>
>>
>> what incompatibilities do you see between 4.7 and 4.8 ?
>>
>
> I saw this in the gcc 4.8 changelog:
> "On ARM, a bug has been fixed in GCC's implementation of the AAPCS rules
> for the layout of vectors that could lead to wrong code being generated.
> Vectors larger than 8 bytes in size are now by default aligned to an 8-byte
> boundary. This is an ABI change: code that makes explicit use of vector
> types may be incompatible with binary objects built with older versions of
> GCC. Auto-vectorized code is not affected by this change.”
>
>
> OK. are you seeing this use case here ?
>

Nope I've not hit it nor gone through the calls between the blobs and the
surrounding code.

I just think it makes sense to compile the blobs with a compiler similar to
the one provided by oe-core, to avoid the risk...

--Richard
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-ti/attachments/20140212/22189727/attachment.html>


More information about the meta-ti mailing list