[meta-ti] No /sbin/init when deriving m7y own image

Hervé Fache h-fache at ti.com
Mon Oct 15 00:24:34 PDT 2012


On 10/12/2012 06:19 PM, Denys Dmytriyenko wrote:
> On Fri, Oct 12, 2012 at 05:58:39PM +0200, Herv? Fache wrote:
>> On 10/12/2012 05:31 PM, Denys Dmytriyenko wrote:
>>> On Fri, Oct 12, 2012 at 05:27:43PM +0200, Herv? Fache wrote:
>>>> Hi guys,
>>>> I am new to Poky and have created the following recipe:
>>>>      require recipes-graphics/images/core-image-x11.bb
>>>>      IMAGE_INSTALL += "omapdrmtest"
>>> Can you try adding to CORE_IMAGE_EXTRA_INSTALL instead of IMAGE_INSTALL?
>> Thanks a lot, that did it!
> I'm glad it worked for you.
> But I'm still baffled why IMAGE_INSTALL didn't work. The only 2 reasons I can
> see for that are:
> 1. If you made a typo and used '=' instead of '+=', which would re-assign
> IMAGE_INSTALL, instead of appending to it, losing its current value.
> 2. Or if you tried to append to IMAGE_INSTALL before loading the base image
> recipe with 'require' (effectively, swapping the 2 lines of your recipe) - in
> that case you'd append to an empty IMAGE_INSTALL first and inside the
> core-image class it uses conditional assignment to pre-set that variable with
> system defaults. But since you already assigned to it early on, it won't be
> populated with system defaults...
> Other than that, the example you showed above seems to work for me here...
Well, I just copied and pasted into the e-mail, so what you see it what 
I had :-)
And FWIW I also tried to add spaces everywhere to no avail!


More information about the meta-ti mailing list