[meta-ti] Beaglebone + Poky

Jack Mitchell ml at communistcode.co.uk
Thu May 24 07:25:50 PDT 2012

On 23/05/12 14:40, Jack Mitchell wrote:
> On 23/05/12 11:51, Gary Thomas wrote:
>> On 2012-05-23 02:44, Jack Mitchell wrote:
>>> On 22/05/12 17:31, Denys Dmytriyenko wrote:
>>>> On Tue, May 22, 2012 at 05:03:53PM +0100, Jack Mitchell wrote:
>>>>> On 22/05/12 16:57, Gary Thomas wrote:
>>>>>> On 2012-05-22 09:48, Jack Mitchell wrote:
>>>>>>> Hi,
>>>>>>> I am currently trying to boot my beagleboard with a mix of
>>>>>>> Poky/Meta-ti/meta-oe, I can build the image without error
>>>>>>> however when I start booting the board the kernel gets to
>>>>>>> 'freeing init memory' and seems to hang, although the beaglebone
>>>>>>> light is still flashing and it will still accept keystrokes.
>>>>>>> Could anyone shed any light on the situation?
>>>>>>> I am on the denzil branch for all three repositories.
>>>>>>> I have tried with USB only and USB + AC Adapter.
>>>>>> What image did you use?
>>>>> core-image-minimal - it does have a few extra programs added via
>>>>> IMAGE_INSTALL but they are userspace only so shouldn't be affecting
>>>>> the boot.
>>>> Couple suggestions:
>>>> 1. What's your init system? Since you have meta-oe mixed with poky, 
>>>> check if
>>>> there are any problems with sysvinit or systemd, in case there is 
>>>> some mix up
>>>> or confusion between those two...
>>>> 2. Check your /etc/inittab for the correct tty used for getty, but 
>>>> it doesn't
>>>> look like it reaches the prompt yet...
>>> I am using Poky defaults so I assume it will be sysvinit... however 
>>> I did see systemd being built, what would be the outline procedure 
>>> to check that mixing of systems isn't
>>> occurring? None of my reciepes have systemd support, but I assume 
>>> something being pulled in from meta-oe does...
>>> My getty is being pushed to ttyO0, is this correct for the beaglebone?
>> Can you put your images somewhere where I can access them?  I can give
>> you an FTP push site if that helps?  I'd like to run through your image
>> here on my BeagleBone.
>> BTW, the only way meta-oe could be causing problems would be if you are
>> using some recipe from it.  If you build exactly 'core-image-minimal' 
>> with
>> no extra packages, does it work for you?
> Hi Gary,
> I just tried without my addional programs to build a 
> core-image-minimal and it still halts on the same kernel message. 
> Something that I forgot to mention the yesterday was that I have a 
> very high debugging level set, here is my local conf line:
> EXTRA_IMAGE_FEATURES = "debug-tweaks tools-debug tools-profile dbg-pkgs"
> Which could cause other programs to be brought in?
> Regards,
> Jack.

Just a quick note that removing meta-oe and just porting over the 
specific recipes that I needed fixed my problems. I still don't know 
specifically what they were but I am inclined to say they were init 
system related as Denys pointed out.



   Jack Mitchell (jack at embed.me.uk)
   Embedded Systems Engineer


More information about the meta-ti mailing list