<div dir="ltr">We use the Angstrom distro 1.7<div><br><div>Our structure does not look like that. Whats this Yocto business?</div><div><br></div><div>Looks like script is being called from the wrong directory then.</div></div><div><br></div><div><br></div></div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Feb 17, 2015 at 6:18 PM, Otavio Salvador <span dir="ltr"><<a href="mailto:otavio@ossystems.com.br" target="_blank">otavio@ossystems.com.br</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">On Tue, Feb 17, 2015 at 1:09 PM, Werner Grift <<a href="mailto:sky.captin@gmail.com">sky.captin@gmail.com</a>> wrote:<br>
> The device tree issue I refer too is the device tree file that is not being<br>
> copied to the boot partition because the generated script<br>
> create_image.sdcard contains if statements that assume that the current<br>
> working directory is ${DEPLOY_DIR_IMAGE} which it is not. In my case it was<br>
> ${OE_BASE} which makes sense since it is where bitbake is called from.<br>
<br>
</span>How is your platform setup?<br>
<br>
FSL Community BSP usually looks like:<br>
<br>
.<br>
├── build<br>
│   └── conf<br>
├── README<br>
├── setup-environment<br>
└── sources<br>
    ├── base<br>
    ├── Documentation<br>
    ├── meta-fsl-arm<br>
    ├── meta-fsl-arm-extra<br>
    ├── meta-fsl-demos<br>
    ├── meta-openembedded<br>
    └── poky<br>
<br>
Is yours same layout?<br>
<div class="HOEnZb"><div class="h5"><br>
--<br>
Otavio Salvador                             O.S. Systems<br>
<a href="http://www.ossystems.com.br" target="_blank">http://www.ossystems.com.br</a>        <a href="http://code.ossystems.com.br" target="_blank">http://code.ossystems.com.br</a><br>
Mobile: <a href="tel:%2B55%20%2853%29%209981-7854" value="+555399817854">+55 (53) 9981-7854</a>            Mobile: <a href="tel:%2B1%20%28347%29%20903-9750" value="+13479039750">+1 (347) 903-9750</a><br>
</div></div></blockquote></div><br></div>