<div dir="ltr"><div><div><div><div><div><div>Hello,<br><br></div>I'm seeing some unexplained changes in the buildhistory when I do incremental builds of the SD-images. The wayland packages from gpu-viv-bin-mx6q recipe seem to have an unspecified dependency on libffi:<br>
<br> PKG = libwayland-viv0<br> RPROVIDES = <br>-RDEPENDS = eglibc (>= 2.19)<br>+RDEPENDS = eglibc (>= 2.19) libffi (>= 3.0.13)<br><br></div>Several of the dev/debug-packages also have this change:<br><br>  libegl-dbg<br>
  libgc-wayland-protocol-dbg<br>  libgc-wayland-protocol-dev<br>  libgc-wayland-protocol0<br>  libgl-dbg<br>  libglesv2-dbg<br>  libwayland-viv-dbg<br>  libwayland-viv-dev<br>  libwayland-viv0<br><br></div>Looking into log.do_package I see:<br>
<br>  log.do_package:DEBUG: libwayland-viv-mx6: Dependency libffi.so.6 requires package libffi<br>  log.do_package:DEBUG: libgc-wayland-protocol-mx6: Dependency libffi.so.6 requires package libffi<br><br></div>In what I think is one of the older log-files I see this:<br>
<br>  NOTE: Couldn't find shared library provider for libffi.so.6, used by files: [...]<br><br></div>So it seems to me that some of the sub-packages needs a RDEPEND on libffi.<br><br></div>/Jacob<br></div>