<div dir="ltr">I use a yocto1.4 build from the freescale site and trying build my own packages. I created my own layer in wihich I have recipes for two packages, flex and bison, which work fine.<div>I have configured wireshark like:<br>

<br>ESCRIPTION = "Wireshark packet sniffer"<br>SECTION = "Packet sniffer"<br>LICENSE = "GPLv2+"<br>LIC_FILES_CHKSUM = "file://COPYING;md5=0aeec08d1d1a8070a2d26af094b8f503"<br><br>PR = "r0"<br>

<br># RPROVIDES_${PN} = "wireshark"<br><br>SRC_URI = "file:///home/qoriq/wireshark-1.10.5.tar.bz2"<br>SRC_URI[md5sum] = "a66894a62f05e1e7a3156a807f3296ea"<br><br>inherit autotools gettext<br>

<br><br><br></div><div>And in my conf/local.conf file. I have the variable<br></div><div>IMAGE_INSTALL_append = " flex bison wireshark"<br></div><div>And I also added my layer in the conf/bbclasses.conf file.</div>
<div><br></div><div>THe flex and the bison packages are built perfectly fine but the wireshark package throws an error.<br>
ERROR: Nothing RPROVIDES 'wireshark' (but /home/qoriq/yocto/meta-fsl-networking/images/<a href="http://fsl-image-full.bb" target="_blank">fsl-image-full.bb</a> RDEPENDS on or otherwise requires it)<br>NOTE: Runtime target 'wireshark' is unbuildable, removing...<br>

Missing or unbuildable dependency chain was: ['wireshark']<br>ERROR: Required build target 'fsl-image-full' has no buildable providers.<br>Missing or unbuildable dependency chain was: ['fsl-image-full', 'wireshark']<br>

<br>When I separately tried to build wireshark. I did get an error nothing provies wireshark.</div><div><br></div><div>And also I did get a Warning</div><div><div><br></div><div>WARNING: No bb files matched BBFILE_PATTERN_mylayer '^/home/qoriq/yocto/meta-mylayer/'</div>
</div><div><br></div><div>Is this related to the above problem? How do i solve it?</div>
</div>