[meta-freescale] [thud][fsl-community-bsp] building a correct sd card image

Jean-Michaël Celerier jean-michael.celerier at kdab.com
Mon Mar 18 03:24:50 PDT 2019


I have done the following procedure to try to build an image for my i.MX6 :
- get the fsl-community-bsp repository on branch thud
- run setup-environment like this :

    MACHINE=imx6qdlsabresd DISTRO=fslc-framebuffer ./setup-environment build

- bitbake core-image-minimal
- put the built image on a sd card with wic

The sdcard goes to uboot, but isn't able to boot the linux kernel afterwards 
(it hangs at "Decompressing kernel..." from what I can see).

I also tried with fsl-image-machine-test with the same result.

Would anyone know what is going wrong ? The card boots fine with the official 
freescale BSP.

Here are my variables: 

BB_VERSION = "1.40.0"
BUILD_SYS = "x86_64-linux"
TARGET_SYS = "arm-fslc-linux-gnueabi"
MACHINE = "imx6qdlsabresd"
DISTRO = "fslc-framebuffer"
TUNE_FEATURES = "arm armv7a vfp thumb neon callconvention-hard"
TARGET_FPU = "hard"
meta meta-poky = "HEAD:f5a57e939e626a5b7c6de5b51799ca602ed355ed"
meta-oe meta-multimedia = "HEAD:6ef9657068492d4644079c88f2adee9c3cac9543"
meta-freescale = "HEAD:6a43f14bce556189cb8e7338148b777ca6f6141a"
meta-freescale-3rdparty = "HEAD:815df63f9b8997623fe9e23c78de736c25f0a4fd"
meta-freescale-distro = "HEAD:ef7e7ec8141c5099ba87c766108f698b9cc2e9a0"

Kind regards,

More information about the meta-freescale mailing list