[meta-freescale] Error compiling barebox on fido

György Kövesdi kgy at teledigit.eu
Mon Jun 22 07:38:12 PDT 2015

Hi Nikolay,

I found something.
As you suggested, i created a small test recipe. It was succeeded on 
master and fido checkouts too.
I found that it uses gcc this way:

arm-poky-linux-gnueabi-gcc  -march=armv7-a -marm  -mthumb-interwork 
-mfloat-abi=hard -mfpu=neon -mtune=cortex-a9 
-O2 -pipe -g -feliminate-unused-debug-types  -Wl,-O1 
-Wl,--hash-style=gnu -Wl,--as-needed  x.c   -o x

The first some options passed to gcc fixes my problem:

-march=armv7-a -marm  -mthumb-interwork -mfloat-abi=hard -mfpu=neon 

and the others are come from CFLAGS and LDFLAGS variables.
If i could pass these to barebox compilation, then i could fix it. My 
problem is that i could not find the variable where these options are 
Can you help me to find the place of these options?

Thanks in advance
Gyorgy Kovesdi

On 2015-06-22 13:33, Nikolay Dimitrov wrote:
> Hi György,
> On 06/22/2015 02:17 PM, György Kövesdi wrote:
>> Hi,
>> I tried to switch back to gcc 4.8 on fido, but the same error occurs.
>> Is the gcc built differently on fido?
> [snip]
> Well, there's no "-nostdinc" directive, so these include paths should be
> there. Also, in the devtools recipe gcc-4.9 seems to be compiled with
> proper include paths.
> I think there could be an issue with your recipe, as I can build custom
> components that uses stdio.h on Fido without such errors. Also, there a
> quite a lot of components that include the same header and seem to build
> again without issues (alsa, pulseaudio, xz and others).
> Can you please verify this issue on a clean Fido, that wasn't modified
> in any way, and with a very simple recipe?
> Regards,
> Nikolay

More information about the meta-freescale mailing list