[meta-freescale] Correction: Yocto Dizzy. Adding device tree to boot directory.

Tord Andersson tord.andersson at endian.se
Tue Nov 18 08:31:37 PST 2014

Corrected question.


I currently try to figure out the best way to put the device tree inside the boot directory (/boot) of the root file system along with the kernel.
Tried this on Wandboard by adding the following to core-image-base:

IMAGE_BOOT_FILES += "uImage uImage-imx6q-wandboard.dtb"

Didn't succeed though, the old image uImage file with link was still there after clean/rebuild.
The uImage file (link) and dtb existed in the deployment area but the device tree was not copied.

Also tried with the default KERNEL_IMAGETYPE (zImage) and associated changes but this made no change,

IMAGE_BOOT_FILES += "zImage zImage-imx6q-wandboard.dtb"

I got a zImage in the boot directory instead and no device tree.

I have probably missed some easy part! :)

Maybe i should use ROOTFS_POSTPROCESS_COMMAND instead, but I guess there are better ways!

Best regards,


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 203 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20141118/8077c438/attachment.pgp>

More information about the meta-freescale mailing list