[meta-freescale] EDID on imx6 (was 'No HDMI video on imx6qsabresd with dizzy')

Andreas Müller schnitzeltony at googlemail.com
Fri Nov 14 00:37:54 PST 2014

Hi Nicolay,

I opened a new thread - my HDMI problems was unrelated to yours (and
your problem is solved).

On Thu, Nov 13, 2014 at 8:34 PM, Nikolay Dimitrov <picmaster at mail.bg> wrote:
> Hi guys,
> Thanks to Fabio the HDMI is now working. Here's how:
> 1. Disabled HDMI support in u-boot-fsl (actually disabled all video-
> related support, as it was easier/faster).
> 2. Added the usual video configuration to "mmcarg" env-var:
> video=mxcfb0:dev=hdmi,1280x720M at 60,if=RGB24
> 3. Booted the board (had to set mmcdev to 0 as I boot from SD2).
> 4. Observed that Xorg was running on the HDMI screen.
> 5. Played video via gstreamer and observed it's rendering on the screen
> without issues.
> After discussion with Andreas, I tested the following resolutions and
> they worked OK:
> - 640x480
> - 800x600
> - 1024x768
> - 1280x720
> (just don't have the time to test more as these were OK for my tests)
I am wondering: It seems I am the only one with fixed 640x480
resolution on unpatched freescale kernel.

For me to understand more: Could you enter the following on device's
console with one working environment and monitor connected during

for f in `find /sys -name edid`; do echo $f; cat $f; done

and send me the result. This would help me much to understand why I
need the patches attached in earlier email and you don't need them.



More information about the meta-freescale mailing list