[meta-freescale] What image should I build on the SabreLite?

Philippe BALLEYDIER PBalleydier at visionsystems.fr
Thu Nov 13 03:09:47 PST 2014

Hi everyone.

>De : Eric Nelson [eric.nelson at boundarydevices.com]
>Envoyé : vendredi 7 novembre 2014 14:55
>À : Philippe BALLEYDIER
>Cc : meta-freescale at yoctoproject.org
>Objet : Re: [meta-freescale] What image should I build on the SabreLite?
>Hi Philippe,
>On 11/07/2014 03:00 AM, Philippe BALLEYDIER wrote:
>> Hi
>> I did the same as you on fsl-image-multimedia-full
>> Here's what i get:
>> root at nitrogen6x:~# cat /proc/version
>> Linux version 3.10.17-1.0.1_ga+yocto+g9f710da (philippe at philippe-HP-ProBook-4730s) (gcc version 4.9.1 (GCC) ) #1 SMP Fri Nov 7 08:50:50 CET 2014
>> root at nitrogen6x:~# dmesg | grep ov5642
>> update_device_addr: ov5642 ret=-110
>> ov5642_read_reg:write reg error:reg=300a
>> camera ov5642 is not found

>This indicates a problem with the camera or cabling.

I verified the cabling, and it's still not working; So i believe one of the flex is broken, or it's the camera

>> root at nitrogen6x:~# dmesg | grep ov5640
>> ov5640_mipi 1-003e: found pwm2, period=45
>> ov5640_read_reg:write reg error:reg=300a
>> camera ov5640 is not found
>> update_device_addr: ov5640_mipi ret=-110
>> ov5640_read_reg(mipi):reg=300a ret=-110
>> camera ov5640_mipi is not found

>You don't have one of these connected, right?

No i don't. I just tried this command because i wanted to see if something different show up

>> root at nitrogen6x:~# gst-launch --gst-debug-level=2 mfw_v4lsrc ! mfw_v4lsink
>> MFW_GST_V4LSRC_PLUGIN 3.0.11 build on Nov  7 2014 09:23:30.
>> mxc_v4l_open: Mxc Camera no sensor ipu0/csi0
>> mxc_v4l_open: Mxc Camera no sensor ipu1/csi0
>> mxc_v4l_open: Mxc Camera no sensor ipu1/csi1

>If the cameras were "not found", I think you knew what was going
>to happen here!

>> <snip>
>> Is it possible that my camera is dead? How can i make sure of that?
>It's most likely a cabling issue. It's quite easy for the flex cables
>to become dislodged since there aren't any cable stays.

As i said, i unplug/replug every flex, and it is still not working.

>> I managed to make it work once on fsl-image-gui (dora branch). I
>> guess i will rebuild this one just to make sure the camera is still working fine.
>I'd recommend using a pre-built image to shave some time.

>There are quite a few on O.S. Systems CI server:
>        http://ci.ossystems.com.br/public/fsl-community-bsp/master

>This Ubuntu image also contains full camera support:
>        http://boundarydevices.com/ubuntu-trusty-mx6-boards-september-2014/

I used the fsl-image-gui (dora's branch, the one i used before and on which it was working before) and the fsl-image-test on OS Systems CI server.
In both case, the camera is not found. Since it used to work with the fsl-image-gui, it's either the flex or the camera not working.

>> I added the CONFIG_USB_AUDIO to the kernel and i now have a
>> UAC2_Gadget appearing in alsamixer, but no element is showing up: This
>> sound device does not have any controls.
>I'm not sure what you mean by "no element".

>Can you clarify?

When i open alsamixer and press F6 to see what card is available. I see a new sound card called "UAC2_Gadget". When i press enter to select it, there is no equalizer appearing (like MIC, Bass, Treble, Line, etc), just a message saying: "This sound device does not have any controls"

>You mentioned that the SABRE SD board was able to operate with
>your hardware. You might want to compare the defconfig files
>between the two.  Perhaps something is missing.

Yes, i'll try this later and keep you updated

Best regards


More information about the meta-freescale mailing list