[meta-freescale] CLOCAL bit for console ttyAMA0 on imx28evk with 3.14 kernel

Craig McQueen craig.mcqueen at beamcommunications.com
Tue Nov 11 18:06:28 PST 2014

On 12/11/14 10:47, Otavio Salvador wrote:
> On Tue, Nov 11, 2014 at 9:00 PM, Craig McQueen
> <craig.mcqueen at beamcommunications.com> wrote:
>> On 12/11/14 04:53, Otavio Salvador wrote:
>>> On Tue, Nov 11, 2014 at 3:46 PM, Fabio Estevam <festevam at gmail.com> wrote:
>>>> On Tue, Nov 11, 2014 at 3:42 PM, Otavio Salvador
>>>> <otavio at ossystems.com.br> wrote:
>>>>> Is it something which needs fixing on the kernel or Busybox getty?
>>>> It needs to be fixed in Busybox. I tried the same on an LTIB rootfs
>>>> and the problem does not happen there.
>>> Please see if you can identify the option (or patch) we need to apply
>>> in Busybox to solve it.
>>> Another possibility is something on your testing LTIB rootfs to be
>>> adding a stty call somewhere.
>> I tried adding the -L option to the getty line in /etc/inittab:
>> AMA0:12345:respawn:/sbin/getty -L 115200 ttyAMA0
>> That seemed to work. Not sure yet how to patch that in meta-freescale.
> I prepared the patches for OE-Core. I attached both here so you can
> confirm it works for you.
> If it does, I can add your Reported-by and Tested-by credits :)

Great! I have tested the inittab patch, and it works. Thanks. I haven't 
tested the systemd patch.

Craig McQueen

More information about the meta-freescale mailing list