[meta-freescale] Unable to get u-boot running on i.MX6 SABRE for Smart Devices Eval Board

Guillaume Fournier gfournier at brioconcept.com
Wed Nov 5 13:50:58 PST 2014

>> 4) got latest u-boot: git clone 
>> https://github.com/Freescale/u-boot-fslc.git
>> 5) started a fresh shell, ran toolchain environment script, cd to 
>> u-boot-fslc
>Run the environment script raises an alarm... did you use:
>source environment-...?

Yes I ran:
source ./environment-setup-cortexa9hf-vfp-neon-poky-linux-gnueabi
which is located in the toolchain directory.  This sets a bunch of environment variables needed to cross-compile.

>> 6) make LDFLAGS="" CC="$CC" mx6dlsabresd_config
>> 7) make LDFLAGS="" CC="$CC" u-boot.im
>Please try:
>unset LDFLAGS
>make mx6dlsabresd_config
>make u-boot.imx

>From a fresh shell, I ran the toolchain environment script, cd to u-boot-fslc and then typed:
make mrproper
make mx6dlsabresd_config
make u-boot.imx

arm-poky-linux-gnueabi-ld.bfd: cannot find -lgcc
make[2]: *** [examples/standalone/hello_world] Error 1
make[1]: *** [examples/standalone] Error 2
make: *** [examples] Error 2

That error is the reason I was using LDFLAGS="" CC="$CC" on the command line to build.
See : https://lists.yoctoproject.org/pipermail/yocto/2013-October/016385.html

BTW the cfimager works with decimal and hex.  I have read back the SD card using Win32DiskImager (raw reader) and I can confirm this.  Since so many people were doubtful of this cfimager, I used a VM to dd my u-boot onto the SD card as such:
dd if=u-boot.imx of=/dev/sda bs=512 seek=2

This does not solve my problem.  It behaves exactly as the cfimager.  I'm pretty sure now that SD card issues are solved.  I can write a known to work version of u-boot.imx to an SD card and the target boots up fine.

I still do not have a u-boot.imx that can boot with my eval board and this is the main issue.


More information about the meta-freescale mailing list