[meta-freescale] Unable to get u-boot running on i.MX6 SABRE for Smart Devices Eval Board

Eric Bénard eric at eukrea.com
Wed Nov 5 09:25:47 PST 2014

Hi Guillaume,

Le Wed, 5 Nov 2014 09:51:08 -0500,
"Guillaume Fournier" <gfournier at brioconcept.com> a écrit :
> Since I'm using u-boot.BIN, I believe the seek=1 and skip=1 are fine.  I
> have tried this method with a "known-to-work" u-boot.bin and u-boot boots up
> fine on the board.  So the SD card u-boot.bin write part should work as
> expected. 

no u-boot.bin won't work when using a recent version of u-boot, you
_must_ use u-boot.imx

> As suggested, I tried it using the .IMX file using :
>     <CMD state="Updater" type="push" body="send"
> file="axion/u-boot.imx">Sending u-boot.imx</CMD>
>     <CMD state="Updater" type="push" body="$ dd if=$FILE of=/dev/mmcblk1
> bs=1k seek=1 conv=fsync">write u-boot.imx to sd card</CMD>
> u-boot does not boot on the board either using this method.
maybe you can try to build u-boot with an older toolchain from Linaro to
be sure you don't hit a toolchain problem.
And if you can try to use dd on a Linux box at least you will be sure
that it's not a configuration problem with the windows tools and


More information about the meta-freescale mailing list