[meta-freescale] Unable to get u-boot running on i.MX6 SABRE for Smart Devices Eval Board

Guillaume Fournier gfournier at brioconcept.com
Wed Nov 5 06:51:08 PST 2014


Since I'm using u-boot.BIN, I believe the seek=1 and skip=1 are fine.  I
have tried this method with a "known-to-work" u-boot.bin and u-boot boots up
fine on the board.  So the SD card u-boot.bin write part should work as
expected.  As suggested, I tried it using the .IMX file using :

    <CMD state="Updater" type="push" body="send"
file="axion/u-boot.imx">Sending u-boot.imx</CMD>
    <CMD state="Updater" type="push" body="$ dd if=$FILE of=/dev/mmcblk1
bs=1k seek=1 conv=fsync">write u-boot.imx to sd card</CMD>

u-boot does not boot on the board either using this method.

I do not have physical access to the linux box so I need to use my Windows
box to burn the image.  This does not seem to be part of the problem for now
since I have proven that I can get a known-to-work image to boot fine on the


Sent: November 4, 2014 7:24 PM

Hi Guillaume,

Le Tue, 4 Nov 2014 17:44:08 -0500,
"Guillaume Fournier" <gfournier at brioconcept.com> a écrit :
>         <CMD state="Updater" type="push" body="send"
> file="axion/u-boot.bin">Sending u-boot.bin</CMD>
>         <CMD state="Updater" type="push" body="$ dd if=$FILE
> bs=1k seek=1 skip=1 conv=fsync">write u-boot.bin to sd card</CMD>

-> seek & skip is wrong with u-boot.imx you should use with
u-boot-fslc : you only need seek=1


> 6) Copied u-boot.bin from Linux box ~/axion-dev/u-boot-fslc to Windows
> {INSTALL_FOLDER}\Profiles\MX6DL Linux Update\OS Firmware\axion

--> I think you should take u-boot.imx and not u-boot.bin

a far simpler way if you have a SD slot on your Linux host should be :
dd if=u-boot.imx of=/dev/mmcblk0 conv=notrunc seek=2 bs=512 replace mmcblk0
by the right device (and take care to not erase your hard drive ;-)


More information about the meta-freescale mailing list