[meta-freescale] Problem booting fsl-image-gui with imx6qsabrelite

Morgan McKenzie rmtm at uvic.ca
Fri Mar 7 10:09:39 PST 2014

Just to complement Vigneshwaren's advice - I had a similar issue as well a few months ago and it turned out that the SD card (a cheapo 2GB one I found lying around) was actually the culprit. I bought a better quality one (Class 10, speed is always nice too!) and my problems disappeared!
Morgan McKenzie

Date: Fri, 7 Mar 2014 11:54:15 +0530
From: vigneshwaren.sankaran78 at gmail.com
To: eric.nelson at boundarydevices.com
CC: meta-freescale at yoctoproject.org
Subject: Re: [meta-freescale] Problem booting fsl-image-gui with	imx6qsabrelite

Hi Fredrico,
I am not sure of the status of the problem, if its solved or not, but here is what I recommed.

Before jumping into the u-boot proceedure Eric Nelson had provided, can you check the SD card.

I had a very similar 
Card did not respond to voltage select!

In my u-boot prompt I ran 
=> mmc part
and I saw that the Start Sector, Num Sector and UUID were corrupted. I wsa using GParted to format my SD card.

I switched to fdisk and when I ran it on my board, the partitions were perfect, and 
=> mmcinfo 
responded to a clean output and no errors!!
Please let us know your status, I am very keen to know how this issue is resolved.


On Thu, Mar 6, 2014 at 8:16 PM, Eric Nelson <eric.nelson at boundarydevices.com> wrote:

Hi Federico,

On 03/06/2014 05:36 AM, Federico Vitali wrote:


I have built a fsl-image-gui (poky dora) for imx6qsabrelite. I have

followed the instruction

to burn the sdcard image ona micro sd.

On boot I get the following errors:

This is the problem:

U-Boot 2009.08 (Jul 05 2012 - 15:37:27)

CPU:   Freescale i.MX 6 family 0.0V at 792 MHz

Temperature:   can't get valid data!

mx6q pll1: 792MHz

mx6q pll2: 528MHz

mx6q pll3: 480MHz

mx6q pll8: 50MHz

ipg clock     : 66000000Hz

ipg per clock : 66000000Hz

uart clock    : 80000000Hz

cspi clock    : 60000000Hz

ahb clock     : 132000000Hz

axi clock   : 264000000Hz

emi_slow clock: 29333333Hz

ddr clock     : 528000000Hz

usdhc1 clock  : 200000000Hz

usdhc2 clock  : 200000000Hz-

usdhc3 clock  : 200000000Hz

usdhc4 clock  : 200000000Hz

nfc clock     : 24000000Hz


I2C:   ready

DRAM:   1 GB


JEDEC ID: 0xbf:0x25:0x41

Reading SPI NOR flash 0xc0000 [0x2000 bytes] -> ram 0x276009b8


In:    serial

Out:   serial

Err:   serial

Net:   got MAC address from IIM: 00:19:b8:00:fd:74


Warning: FEC0 MAC addresses don't match:

Address in SROM is         00:19:b8:00:fd:74

Address in environment is  00:01:02:03:04:05

Hit any key to stop autoboot:  0

Card did not respond to voltage select!

mmc0(part 0) is current device

MMC: block number 0x1 exceeds max(0x0)

** Can't read from device 0 **

** Unable to use mmc 0:1 for fatload **

** Bad partition 1 **

mmc1 is current device

reading /6q_bootscript

And this is the key symptom (6q_bootscript):

** Unable to read "/6q_bootscript" from mmc 1:1 **

Loading file "/6q_bootscript" from mmc device 1:1 (xxb1)

Failed to mount ext2 filesystem...

** Bad ext2 partition or disk - mmc 1:1 **

What could be the problem? I've also tried with different images, but

without success.

Yocto includes a boot script that assumes you're using

a main-line version of U-Boot. Because of the incompatibilities

between the 2009.08 code base and main-line, the boot

script was re-named from 6q_bootscript to 6x_bootscript in

the process.

It also generates a U-Boot binary for you, but doesn't

upgrade it in SPI-NOR.

See this post for details:


So to get past this, you need to program the file 'u-boot.imx' from

your SD card, and this is done through the 'upgradeu' command:

        U-Boot > run upgradeu

Unfortunately, the command incompatibilities are in the 'upgradeu'

process as well, so this will fail for you until you copy the

script file '6q_upgrade' from this package:



Note that you only need to copy the one file '6q_upgrade' from that

package into the Boot partition. You should already have a

u-boot.imx file produced by Yocto that is relatively recent.

Finally, the environment variables changed between the two

code bases. To restore them to factory default, you can use

the 'clearenv' command:

        U-Boot > run clearenv.

So, to re-cap:

1.      Copy 6q_upgrade from the 6q_upgrade-20121109.zip package

        into the boot partition of your SD card,

2.      Boot the device and run these commands:

        U-Boot > run upgradeu

        U-Boot > run clearenv

        U-Boot > reset

3.      Enjoy!




meta-freescale mailing list

meta-freescale at yoctoproject.org


meta-freescale mailing list
meta-freescale at yoctoproject.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20140307/36388072/attachment.html>

More information about the meta-freescale mailing list