[meta-freescale] Hob error during dependency tree checking

Timur Aydin ta at taydin.org
Mon Mar 3 05:14:43 PST 2014

Hello Otavio,

I have synced by local repo today and tried with both the master and the 
master-next branch. For some reason, still mesa-9.1.6 is being picked up 
and I am getting the same error. Could it be that this was fixed in a 
development branch that isn't merged to trunk yet?


On 3/3/2014 2:30 PM, Otavio Salvador wrote:
> Hello Timur,
> On Thu, Feb 13, 2014 at 1:57 PM, Timur Aydin <ta at taydin.org> wrote:
>> I am running hob on the master branch (did sync yesterday). Hob stops
>> with the following error dialogs while working on the dependency tree.
>> This was reported earlier on another mailing list, but didn't receive
>> any responses. Any suggestions how to further troubleshoot this? I can
>> work on debugging this if somebody can put me in the right direction.
>> Trying to resolve runtime dependency libgl resulted in conflicting
>> PREFERRED_PROVIDER entries being found.
>> The providers found were:
>> ['/home/ta/fsl-community-bsp/sources/meta-fsl-arm/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-hfp.bb',
>> '/home/ta/fsl-community-bsp/sources/poky/meta/recipes-graphics/mesa/mesa_9.1.6.bb']
>> The PREFERRED_PROVIDER entries resulting in this conflict were:
>> ['PREFERRED_PROVIDER_virtual/libgl = gpu-viv-bin-mx6q',
>> 'PREFERRED_PROVIDER_virtual/mesa = mesa']
> You seem to be using a mix of releases; master has 9.2.5 mesa release
> (IIRC) and has a bbappend file to address this.

More information about the meta-freescale mailing list