[meta-freescale] I think I am missing some critical link, but am lost trying to find it.

Stephen Munnings Stephen.Munnings at nuvation.com
Tue Jun 24 07:28:50 PDT 2014

Hello all,

I have been using the ycoto fsl-community-bsp (branch dora) to build a distribution for a custom hardware design (similar but not identical to the wandboard solo).
We have an application built using Qt - initially developed on an external host, but now being "brought into" the yocto recipe system.
We have added 3 layers to our setup.

a.       A layer for the board changes (BSP layer) - also has the image recipes

b.      A layer for the distro - and very little else - this could perhaps have been merged into one of the other two layers, but I do think it should stay a separate layer

c.       A layer for the application itself and associated support files and directories. (e.g. The startup script is in here also)

I am having two problems with this setup that are probably related.

1.        When I attempt to build the application (using Qt 5.1), it does not find the toolchain for it.

a.       I get a message about arm-poky-linux-gnueabi-gcc Command not found.

b.      If I search for the toolchain, I find it in : /home/user/<project>/yocto/fsl-community-bsp/build/tmp/sysroots/x86_64-linux/usr/bin/cortexa9hf-vfp-neon-poky-linux-gnueabi/

c.       If I add this path to $PATH, then the build works.  However, I think that this is "kludging my way around the problem"

d.      One (I think) big clue is that the build creates a number of directories in .../tmp/work:

                                                               i.      all-poky-linux

                                                             ii.      all-pokysdk-linux

                                                            iii.      cortexa9hf-vfp-neon-mx6-poky-linux-gnueabi

                                                           iv.      cortexa9hf-vfp-neon-poky-linux-gnueabi

                                                             v.      <custom board>-poky-linux-gnueabi

                                                           vi.      x86_64-linux

                                                          vii.      x86_64-nativesdk-pokysdk-linux

                                                        viii.      x86_64-pokysdk-linux

e.      I find most (but not all) of my recipes are built in <custom board>-poky-linux-gnueabi (no big surprise there)

f.        I find that the required toolchain was built with "cortexa9hf-vfp-neon-poky-linux-gnueabi" in the path name.  I am wondering if this is at the root of my problem?

g.       I have tried changes with the PKG_ARCH variable in my recipes, but they just generally get messy without resolving anything.

                                                               i.      right now, it is: PACKAGE_ARCH = "${MACHINE_ARCH}"

                                                             ii.      I have tried: PACKAGE_ARCH = "${MACHINE_SOCARCH}" - just made it worse.

                                                            iii.      Could not find anything else that should have been used (maybe I just don't look all that well?)

h.      There is no problem with building the Qt components (without using the modified $PATH) and they show up in "cortexa9hf-vfp-neon-poky-linux-gnueabi"

i.         There is no problem (apparently) with qtbase either, but it shows up in "cortexa9hf-vfp-neon-mx6-poky-linux-gnueabi"  (extra mx6 in the name)

2.       The second problem (probably related) is that I cannot get the qsqlite.so (sql lite driver plugin) to build in this setup.

a.       I have added the line "PACKAGECONFIG_append = " sql-sqlite" into a file "qtbase_5.1.1.bbappend" in my application layer.

b.      There are no resulting errors, but also no qsqlite.so driver built into my final image either

c.       I have tried a variety of different ways to do this - reference a prior thread in this mailing list - How do I add the QSQLITE driver to the yocto build for wandboard

d.      I did get it working for the (supplied) wandboard build, but when trying to build for our custom board, I cannot seem to get it generated (anywhere - used find to search entire tmp/work tree)

e.      I suspect that it is related to the first issue noted above

I am a veteran in embedded software, but a newbie to yocto, bitbake, and openembedded.
Keeping that in mind, can someone offer some guidance on what might be wrong here, and how to go about resolving it?


Stephen Munnings
stephen.munnings at nuvation.com<mailto:stephen.munnings at nuvation.com> | www.nuvation.com<http://www.nuvation.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20140624/b857c735/attachment-0001.html>

More information about the meta-freescale mailing list