[meta-freescale] Linux-imx Git Issues

Otavio Salvador otavio at ossystems.com.br
Tue Jun 3 10:11:05 PDT 2014

Hello Lauren,

On Tue, Jun 3, 2014 at 10:46 AM, Lauren Post <Lauren.Post at freescale.com> wrote:
> On Mon, Jun 2, 2014 at 5:34 PM, Nick Gordon <nick.gordon at videon-central.com> wrote:
>> I'm curious about the current state of the servers for the
>> linux-2.6-imx repository. I'm trying to rebuild my kernel for
>> linux-imx as opposed to linux-boundary now, and it seems that during
>> the bitbake it always fails the git operations for the URL git://git.freescale.com/imx/linux-2.6-imx.git.
>> I've tried going through the mirrors, but that doesn't seem to work
>> (though I may not be accessing the mirrors correctly) and I've tried
>> manually running the git commands, but also to no avail. Anyone have
>> any knowledge on this issue?
> Adding Lauren so she can check internally.
> [Lauren Post] No I have not heard of this issue that our git.freescale.com repositories were having failures to access.  I have one team that uses only the external gits for linux and uboot for building since their work is based off of daisy 3.10.17 GA.  I just did a build yesterday for them with external gits with no problems.
> Are you using the right branch?

The only way we can be sure it is right is using:

bitbake linux-imx -c cleanall

and than building it again. Otherwise it reuses the downloaded cache
of the GIT repository so just checking if the revision is available
there and not redownloading it.

Please perform this test so we are sure it is working as fetching
errors is a critical issue especially for new users.


Otavio Salvador                             O.S. Systems
http://www.ossystems.com.br        http://code.ossystems.com.br
Mobile: +55 (53) 9981-7854            Mobile: +1 (347) 903-9750

More information about the meta-freescale mailing list