[meta-freescale] Booting 3.5.7 kernel on imx6sabresd?

randy.krakora at freescale.com randy.krakora at freescale.com
Wed Jan 22 09:47:56 PST 2014

Ahhh, yes, Otavio's suggestion for my original uboot, it works now. And my wife always claims she has to tell me things twice...I guess I should believe her now.

So that worked. Then I went back to my original built image ( uboot, kernel and dtb file ) and burned it again and now it works, not sure why, although maybe I didn't really change fdt_addr before when Otavio mentioned it?

Either way, probably beginner's luck, bad followed by good. Thanks for all your support and patience.

Randy Krakora
-----Original Message-----
From: Fabio Estevam [mailto:festevam at gmail.com] 
Sent: Wednesday, January 22, 2014 10:10 AM
To: Krakora Randy-B37740
Cc: Angolini Daiane-B19406; Otavio Salvador; meta-freescale at yoctoproject.org
Subject: Re: [meta-freescale] Booting 3.5.7 kernel on imx6sabresd?

On Wed, Jan 22, 2014 at 1:06 PM, randy.krakora at freescale.com <randy.krakora at freescale.com> wrote:
> Ok, so I found the prebuilt images for my board here:
> http://autobuilder.yoctoproject.org/pub/releases/CURRENT/machines/imx6
> qsabresd/
> I burned a card with one - core-image-minimal-imx6qsabresd.sdcard. It seemed to work to boot the kernel, so I copied my kernel and .dtb file to that card and it booted as shown below.
> reading boot.scr
> ** Unable to read file boot.scr **
> reading uImage
> 4667456 bytes read in 215 ms (20.7 MiB/s) Booting from mmc ...
> reading imx6q-sabresd.dtb
> 46128 bytes read in 20 ms (2.2 MiB/s)
> ## Booting kernel from Legacy Image at 12000000 ...
>    Image Name:   Linux-3.5.7-1.0.0+3285970
>    Image Type:   ARM Linux Kernel Image (uncompressed)
>    Data Size:    4667392 Bytes = 4.5 MiB
>    Load Address: 10008000
>    Entry Point:  10008000
>    Verifying Checksum ... OK
> ## Flattened Device Tree blob at 11000000
>    Booting using the fdt blob at 0x11000000
>    Loading Kernel Image ... OK
> OK
>    Using Device Tree in place at 11000000, end 1100e42f
> Starting kernel ...
> <Hung here for many minutes>

Ok, ,at least now you don't get the CRC kernel error.

Try doing this in the U-boot prompt:

=> setenv fdt_addr 0x18000000
=> save
=> reset


Fabio Estevam

More information about the meta-freescale mailing list