[meta-freescale] imx6q imx-test failure with x11 disabled

Otavio Salvador otavio at ossystems.com.br
Fri Jan 17 18:57:22 PST 2014

Hello Morgan,

On Fri, Jan 17, 2014 at 11:06 PM, Morgan McKenzie <rmtm at uvic.ca> wrote:
> I tried looking through the dependencies to see why imx-test is being
> included but didn't really get anywhere.. I've pasted the image file I made
> below. I tried removing tslib-tests in case it was what it was requiring
> imx-tests but that didn't get anywhere.
> I also noticed this in the source folder for tslib  -
> mxc_x11_test-exclude-IMX-5-6-platforms.patch  - which would theoretically
> solve the problem but it doesn't actually seem like it is applied.

Please report an issue about this in our bugzilla so we can track this issue.

This patch was indeed not being used and I in fact remove it in the
patchset I just send.

The right fix for this is to make imx-test to handle build options so
we can pass X11=1 for the Makefile and enable the tests which require
X11 support.

Are you willing to work in the patch for it? I can help if need.

Otavio Salvador                             O.S. Systems
http://www.ossystems.com.br        http://code.ossystems.com.br
Mobile: +55 (53) 9981-7854            Mobile: +1 (347) 903-9750

More information about the meta-freescale mailing list