[meta-freescale] Fwd: About Yocto and Imx6

jigar chokshi jigar.chokshi89 at gmail.com
Wed Apr 30 01:23:54 PDT 2014

---------- Forwarded message ----------
From: John Weber <rjohnweber at gmail.com>
Date: Thu, Apr 17, 2014 at 4:18 PM
Subject: Re: [meta-freescale] About Yocto and Imx6
To: "meta-freescale at yoctoproject.org" <meta-freescale at yoctoproject.org>

 Hi Jigar,

Please do not top post.  This means we prefer that you reply with
comments/responses inline with the previous message so that others in the
list can more easily follow the conversation.

On 4/17/14, 4:43 AM, jigar chokshi wrote:

   Hello John,
 I have a question regarding your suggestion.

 Do i have to create another directory for bitbake meta-ide-support or i
have to do bitbake in the same directory where i did bitbake core-image

Bitbake needs to be run in the build directory always.

>Hello sorry for late response. i was busy in another work.
>First i did    bitbake core-image-base in build directory.
>after that i created 1 more directory called buildcoreimage in this
directory i did
>bitbake core-image -minimal.
>So now, i did bitbake meta-ide-support in build directory as you told me.

  I am confused because i think bitbake core-image-minimal
will also generate new image then if i want to use core-image-minimal then
what i have to do?

If you run bitbake core-image-minimal again, and if you changed something
in any of the image dependencies, then it will build a new image.

Running bitbake meta-ide-support does not require that you rebuild your
image - you wanted to be able to build applications using the toolchain and
libraries in the sysroot and this step builds an environment file that you
can source which does that.

 Thank you,
 Jigar Chokshi

 No problem.  I hope it helps.  In the future, you might want to email the
oe-core mailing list as this question does not specifically pertain to the
Freescale BSP but is more of an general OE question.

>still in /opt/poky/1.5.1/sysroots/cortexa9hf-vfp-neon-poky-linux-gnueabi i
cold not find glib library
>and gllib library in /opt/poky/1.5.1/sysroots/x86_64-pokysdk-linux/usr/lib
is for X86-64. so it is not useful for me.
i can see libglib-2.0.so.0.3600 and that is for >ARM i checked with file
command. so, i need this library i am sure.
>Now when i tried to cross compile my library using
>./configure --prefix=/home/x-chokshij/hmi_rbg/libudcu-arm/_Install
CC=arm-poky-linux-gnueabi-gcc CXX=arm-poky-linux-gnueabi-g++
--host=arm-poky-linux-gnueabi --enable-shared --disable-static
>i got error.
>configure: error: in `/home/x-chokshij/Desktop/hmi_rbg/libudcu':
>configure: error: C compiler cannot create executables
>See `config.log' for more details
>i checked config.log file and i found 3 errors as following

>configure:3117: arm-poky-linux-gnueabi-gcc -V >&5
>arm-poky-linux-gnueabi-gcc: error: unrecognized command line option '-V'
>arm-poky-linux-gnueabi-gcc: fatal error: no input files
>compilation terminated.
>configure:3128: $? = 1
>configure:3117: arm-poky-linux-gnueabi-gcc -qversion >&5
>arm-poky-linux-gnueabi-gcc: error: unrecognized command line option
>arm-poky-linux-gnueabi-gcc: fatal error: no input files
>compilation terminated.
>configure:3128: $? = 1
>configure:3148: checking whether the C compiler works
>configure:3170: arm-poky-linux-gnueabi-gcc
>conftest.c  >&5
cannot >find /lib/libc.so.6
cannot >find /usr/lib/libc_nonshared.a
cannot >find /lib/ld-linux-armhf.so.3
>collect2: error: ld returned 1 exit status

 On Wed, Apr 16, 2014 at 3:54 PM, John Weber <rjohnweber at gmail.com> wrote:

> Hi Jigar,
> On 4/16/14, 7:49 AM, jigar chokshi wrote:
>> Hello,
>> Here i attached important parameter of my local.conf file of
>> core-image-minimal.
>> MACHINE ??= 'imx6qsabreauto'
>> DISTRO ?= 'poky'
>> PACKAGE_CLASSES ?= "package_rpm"
>> EXTRA_IMAGE_FEATURES = "debug-tweaks ssh-server-openssh"
>> IMAGE_INSTALL_append = " gcc g++ binutils libgcc libgcc-dev libstdc++
>> libstdc++-dev glib-2.0 libsigc++-2.0-dev libstdc++-staticdev tslib-conf
>> tslib-tests tslib-calibrate openssh-sftp-server alsa-lib alsa-tools
>> alsa-state alsa-utils-alsaconf tslib evtest dbus nano qtbase qtbase-fonts
>> qtbase-plugins qtbase-examples cinematicexperience gstreamer cairo pango
>> fontconfig freetype pulseaudio "
>> DISTRO_FEATURES_remove = "x11 wayland"
>> I tried to cross compile qt5 using poky tool chain and it was successful.
>> Now when i tried build an application using same tool chain it required
>> an library that is developed by my colleague.
>> so, when i tried to configured that library.
>> echo $PATH
>> /usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/opt/poky/1.5.1/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi
>> ./configure --prefix=/home/x-chokshij/hmi_rbg/libudcu-arm/_Install
>> CC=arm-poky-linux-gnueabi-gcc CXX=arm-poky-linux-gnueabi-g++
>> --host=arm-poky-linux-gnueabi --enable-shared --disable-static
>> Now when i am giving make all
>> i am getting following error
>> /opt/poky/1.5.1/sysroots/x86_64-pokysdk-linux/usr/libexec/arm-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/4.8.1/ld:
>> cannot find -lglib-2.0
>> I understand this error is because poky cant find glib-2.0 library. but
>> as you can see in local.conf file i installed glib-2.0 lib.
>  I think you need other environment variables set in order for your
> configure script to find the shared libraries (e.g. PKGCONFIG).  You might
> give this a try:
> bitbake meta-ide-support
> then
> source ./tmp/environment-setup-cortexa9hf-vfp-neon-poky-linux-gnueabi
> I believe that this should take care of most of it.  Let us know how it
> goes.
> John
> --
> _______________________________________________
> meta-freescale mailing list
> meta-freescale at yoctoproject.org
> https://lists.yoctoproject.org/listinfo/meta-freescale

meta-freescale mailing list
meta-freescale at yoctoproject.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20140430/04cb681d/attachment.html>

More information about the meta-freescale mailing list