[meta-freescale] SX-SDCAN Ath6kl firmware

Otavio Salvador otavio at ossystems.com.br
Sun Apr 20 20:38:33 PDT 2014

Hello Morgan,

On Thu, Apr 10, 2014 at 12:08 AM, Morgan McKenzie <rmtm at uvic.ca> wrote:
> I'm sorry I left this on the backburner for so long - I solved the problem a
> little while ago and I've been meaning to send this and just haven't had the
> chance.

No problem. Life is always in a rush :)

> I've managed to solve the issue to my satisfaction; I have the board booting
> and reliably connecting to wifi. However, I don't think that the way I did
> it would qualify at all for being put back into the repo. For anyone else
> who might be having/might have the issue, this would probably help though...
> in blacklist.conf, which goes in /etc/modprobe.d/:
>>    install ath6kl /bin/false
> (note that just doing an ordinary blacklist actually still resulted in it
> trying to load when the sdio was recognized, which caused the boot sequence
> to hang for 60 seconds as the module searched for the board data file, so I
> had to force it to fail...)
> And then in an init file, which ignores the blacklist:
>>   modprobe --ignore-install ath6kl

Which kernel version did you try? Have you tried with 3.10.17? or even
newer as 3.14?

Otavio Salvador                             O.S. Systems
http://www.ossystems.com.br        http://code.ossystems.com.br
Mobile: +55 (53) 9981-7854            Mobile: +1 (347) 903-9750

More information about the meta-freescale mailing list