[meta-freescale] About Yocto and Imx6

jigar chokshi jigar.chokshi89 at gmail.com
Wed Apr 16 05:49:57 PDT 2014


Here i attached important parameter of my local.conf file of

MACHINE ??= 'imx6qsabreauto'
DISTRO ?= 'poky'
PACKAGE_CLASSES ?= "package_rpm"
EXTRA_IMAGE_FEATURES = "debug-tweaks ssh-server-openssh"
IMAGE_INSTALL_append = " gcc g++ binutils libgcc libgcc-dev libstdc++
libstdc++-dev glib-2.0 libsigc++-2.0-dev libstdc++-staticdev tslib-conf
tslib-tests tslib-calibrate openssh-sftp-server alsa-lib alsa-tools
alsa-state alsa-utils-alsaconf tslib evtest dbus nano qtbase qtbase-fonts
qtbase-plugins qtbase-examples cinematicexperience gstreamer cairo pango
fontconfig freetype pulseaudio "
DISTRO_FEATURES_remove = "x11 wayland"

I tried to cross compile qt5 using poky tool chain and it was successful.
Now when i tried build an application using same tool chain it required an
library that is developed by my colleague.
so, when i tried to configured that library.

echo $PATH
./configure --prefix=/home/x-chokshij/hmi_rbg/libudcu-arm/_Install
CC=arm-poky-linux-gnueabi-gcc CXX=arm-poky-linux-gnueabi-g++
--host=arm-poky-linux-gnueabi --enable-shared --disable-static

Now when i am giving make all

i am getting following error

cannot find -lglib-2.0

I understand this error is because poky cant find glib-2.0 library. but as
you can see in local.conf file i installed glib-2.0 lib.

I dont know where am i wrong.
Thank you,
Jigar Chokshi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20140416/8ecde059/attachment.html>

More information about the meta-freescale mailing list