[meta-freescale] Yocto + Qt5: Starting at Boot

Jay Cady jcady92 at gmail.com
Tue Apr 8 08:31:33 PDT 2014

Hey guys,

I have been able to setup Yocto with Qt5 on my Wandboard Dual. I can
successfully push and image and run it. To run it, I navigate to
/opt/Test/bin and run this command:

./Test -platform eglfs -plugin tslib

It runs perfectly fine and loads the tslib touch screen drivers and whatnot.

I'd like this application to run right when the Wandboard turns on and
Yocto finishes booting. I tried a bunch of stuff with some success. What I
did was write this file (startup.sh):

/opt/Test/bin/Test -platform eglfs -plugin tslib

Then I put that file in /etc/init.d and changed it's permissions to
executable using:

chmod +x startup.sh

Finally, I ran this command to add it to the init scripts:

update-rc.d startup.sh defaults 99

I used 99 so that it would run after everything else, in case there were
any dependencies that needed to be loaded.

When I power cycle my board, it boots and the image starts after everything
else, but the touch screen driver fails to load and the touch screen does
not work. It says:

ts_open() failed (No such file or directory)

It allows does not allow me to use the console anymore (for whatever
reason), forcing me to pop the micro SD into linux and manually comment the
startup script so that I can get console back.

Does anyone know how to solve this problem? I'm not sure why the touch
screen wouldn't work in the boot script, but would work if I run it from
console. Maybe a different way to init it at startup would work?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20140408/0b41e81d/attachment.html>

More information about the meta-freescale mailing list