[meta-freescale] MT9T111/MT9T112 aptina camera driver in linux-imx

Ashwin Kirpalani akcooper8 at gmail.com
Tue Mar 19 16:55:05 PDT 2013

I am attempting to use the Aptina MT9T111 CMOS sensor driver with the
sabrelite board

The linux-imx kernel has the driver for the MT9T112, which needs to be
patched for the MT9T111, or so I thought. The patch that I was attempting
to apply is here:

However, I cannot use the MT9T112.c file that is in the current linux-imx
tree. Turns out my starting point should be the MT9T112.c file in a
repository called linux-media : https://github.com/hvaibhav/linux-media/.

So I tried to copy over into my linux-imx working directory just the
MT9T112.c that is in the linux-media repo and tried to build the kernel but
as you can imagine it led to a whole bunch of errors in soc_camera and
v4l2_mediabus modules.

How would I go about solving this issue? Is there a systematic way (like a
series of patches) that I can use to get me to a working starting point
after which I can apply the above patch.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20130319/87358377/attachment.html>

More information about the meta-freescale mailing list