[meta-freescale] fatal error while init the repo on a nfs mounted drive

Daiane Angolini daiane.angolini at freescale.com
Fri Jun 7 05:29:45 PDT 2013

On 06/07/2013 09:11 AM, Otavio Salvador wrote:
> On Fri, Jun 7, 2013 at 6:25 AM, Thanassis Silis <djnass_18 at hotmail.com
> <mailto:djnass_18 at hotmail.com>> wrote:
>     i am trying to initialize a repo (for yocto development - but it
>     seems to be using the same infrastructure as android).
>     since I lack space on the OS drive, I nfs mounted another disk
>     (filesystem is ext4 but that probably is irrelevant on the
>     mount-client side).
>     I try to initialize the repo with the command
>     |./repo init -uhttps://github.com/Freescale/fsl-community-bsp-platform  -b dylan
>     |
>     and get the error
>     |fatal: unable to start /mnt/lvm/public/.repo/repo/main.py
>     fatal: [Errno 13] Permission denied
>     |
>     Permissions are fine on the disk. manually I can do file operations
>     without a problem.
>     Is it impossible to have the repo on an nfs drive (even at the
>     penalty of slower processing)?
>     Thank you for your help
> I never tried this setup; I use sstate in NFS in some customers but not
> full build system.

I have never tried it as well, but error -13 from NFS when mounting 
rootfs is usually associated with missing 'sudo 
/etc/init.d/nfs-serverXXXX restart'

Double check your /etc/export configuration

More information about the meta-freescale mailing list