[meta-freescale] R: Qt5 with Yocto

Simone cjb.sw.nospam at gmail.com
Fri Dec 20 09:07:30 PST 2013

Hello Alfonso,
I tried to cross compile qt5 for imx6qsabresd following the article at
but I have an error during make.
I'm able to build with bitbake, but not In this standard way.
Below the last part of the build log (after configure, which was completed

make[3]: Entering directory
arm-poky-linux-gnueabi-g++ -c -pipe -mfloat-abi=softfp
--sysroot=/home/alfonso/yocto/build/tmp/sysroots/wandboard-quad -O2 -O2
-mfloat-abi=hard -march=armv7-a -mfpu=neon -DLINUX=1 -DEGL_API_FB=1
-fvisibility=hidden -fvisibility-inlines-hidden -std=c++0x -Wall -W
-D_LARGEFILE_SOURCE -DQT_NO_DEBUG -I../../mkspecs/devices/linux-imx6-g++ -I.
-I../../include -I../../include/QtCore -I../../include/QtCore/5.1.1
-I../../include/QtCore/5.1.1/QtCore -Iglobal -I../3rdparty/pcre
-I../3rdparty/harfbuzz/src -I../3rdparty/md5 -I../3rdparty/md4
-I../3rdparty/sha3 -I.moc/release-shared
-I/home/alfonso/yocto/build/tmp/sysroots/wandboard-quad/usr/include -o
.obj/release-shared/qabstractanimation.o animation/qabstractanimation.cpp
Assembler messages:
Fatal error: can't create .obj/release-shared/qabstractanimation.o:
Permission denied
In file included from ../../include/QtCore/qglobal.h:1:0,
                 from ../../include/QtCore/qnamespace.h:1,
                 from ../../include/QtCore/qobjectdefs.h:1,
                 from ../../include/QtCore/qobject.h:1,
                 from animation/qabstractanimation.h:45,
                 from animation/qabstractanimation.cpp:146:
../../include/QtCore/../../src/corelib/global/qglobal.h:80:21: fatal error:
algorithm: No such file or directory
 #include <algorithm>
compilation terminated.
make[3]: *** [.obj/release-shared/qabstractanimation.o] Error 2
make[3]: Leaving directory
make[2]: *** [sub-corelib-make_first] Error 2
make[2]: Leaving directory `/qt-everywhere-opensource-src-5.1.1/qtbase/src'
make[1]: *** [sub-src-make_first] Error 2
make[1]: Leaving directory `/qt-everywhere-opensource-src-5.1.1/qtbase'
make: *** [module-qtbase-make_first] Error 2

Any hints?

-----Messaggio originale-----
Da: meta-freescale-bounces at yoctoproject.org
[mailto:meta-freescale-bounces at yoctoproject.org] Per conto di Alfonso Tamés
Inviato: venerdì 13 dicembre 2013 12:18
A: koansoftware at gmail.com
Cc: meta-freescale at yoctoproject.org
Oggetto: Re: [meta-freescale] Qt5 with Yocto

Hi Marco,

Indeed, I tried repo init and sync the master branch today and it is
throwing an error about
sources/poky/meta/recipes-support/consolekit/consolekit_0.4.6.bb DEPENDS or
requires virtual/libx11. This while explicit removing X11 in
DISTRO_FEATURES_remove.  Something got messed up in the last 15 days.

I repo synced my yocto_dora directory and tested Qt5_CinematicExperience and
works fine.

Can you specify the errors in yocto_dora? Can you bitbake with the -v



On Dec 13, 2013, at 2:32 AM, Marco <koansoftware at gmail.com> wrote:

> Il 13/12/2013 00:19, Alfonso Tamés ha scritto:
>> Marco,
>> The instructions in
should work for Dora and Master branches. Just remember that master is a
moving target and sometimes it can give problems. Right now I am using
Master without any problems.
>> Regards,
> Hi Alfonso
> that's not true on my side.
> Unfortunately using master branch there is an error downloading the
> OTOH using dora branch there are errors launching the executables on the
imx6dlsabresd target.
> -- 
> Marco

meta-freescale mailing list
meta-freescale at yoctoproject.org

More information about the meta-freescale mailing list