wic create mkhybridiso core-image-minimal failure (honister)


bgctkd@...
 

I'm new to Yocto so this may be simple operator input. 
I built a qemux86-64 image with core-image-minimal using the honister branch of a day or so ago. The build finishes fine, however trying to use:
wic create mkhybridiso -e core-image-minimal, gives the failure below. It looks like a directory is not getting created properly.

(NOTE: wic create directdisk -e core-image-minimal does not give an error).

My local.conf has the following changes from the poky default that I found were recommended in a couple of places at the yocto website.

IMAGE_FSTYPES:append = " wic" 
WKS_FILE:append = " mkhybridiso"
 
SSTATE_MIRRORS = "\
file://.* http://sstate.yoctoproject.org/dev/PATH;downloadfilename=PATH \n \
file://.* http://sstate.yoctoproject.org/3.3.4/PATH;downloadfilename=PATH \n \
file://.* http://sstate.yoctoproject.org/3.4.1/PATH;downloadfilename=PATH \n \
"
 

thinkmate:~/Yocto/TestPoky/poky/build$ wic create mkhybridiso -e core-image-minimal
INFO: Building wic-tools...
 
Loading cache: 100% |###################################################################################################################################| Time: 0:00:00
Loaded 1519 entries from dependency cache.
NOTE: Resolving any missing task queue dependencies
 
Build Configuration:
BB_VERSION           = "1.53.0"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "universal"
TARGET_SYS           = "x86_64-poky-linux"
MACHINE              = "qemux86-64"
DISTRO               = "poky"
DISTRO_VERSION       = "3.4+snapshot-5867838ce7a4a630a3855c01668ec0806820eca2"
TUNE_FEATURES        = "m64 core2"
TARGET_FPU           = ""
meta                 
meta-poky            
meta-yocto-bsp       = "master:5867838ce7a4a630a3855c01668ec0806820eca2"
 
Initialising tasks: 100% |##############################################################################################################################| Time: 0:00:00
Sstate summary: Wanted 0 Local 0 Mirrors 0 Missed 0 Current 207 (0% match, 100% complete)
NOTE: Executing Tasks
NOTE: Tasks Summary: Attempted 932 tasks of which 932 didn't need to be rerun and all succeeded.
INFO: Creating image(s)...
 
ERROR: _exec_cmd: cd ./tmp.wic.f9x8qdi5/INITRD && find . | cpio -o -H newc -R root:root >./tmp.wic.f9x8qdi5/initrd.cpio  returned '2' instead of 0
output: /bin/sh: 1: cannot create ./tmp.wic.f9x8qdi5/initrd.cpio: Directory nonexistent

Thanks in advance for any suggestions,
Bruce
 


bgctkd@...
 

Solution: I poked around and discovered the primary issue is that I was adding wic, but not cpio.gz to IMAGE_FSTYPES