TLV320AIC3104: tlv320aic3104 #yocto #kernel


Amrun Nisha.R
 

Hi,

I am using tlv320aic3104 in one of my project, The hardware is wired in such a way that the I2C lines from tlv320aic3104 is connected to a separate microprocessor which performs the init.

The SAI lines of tlv320aic3104 are connected to IMX8M SAI lines, I am running linux in IMX8M. ALSA says no sound cards found.

I would like to know whether this kind of setup where the i2c is used by a separate processor and using the SAI lines in  a different device that runs linux will work. Kindly advice


Alexandre Belloni
 

Hello,

On 20/06/2021 22:01:48-0700, Amrun Nisha.R wrote:
Hi,

I am using tlv320aic3104 in one of my project, The hardware is wired
in such a way that the I2C lines from tlv320aic3104 is connected to a
separate microprocessor which performs the init.

The SAI lines of tlv320aic3104 are connected to IMX8M SAI lines, I am
running linux in IMX8M. ALSA says no sound cards found.

I would like to know whether this kind of setup where the i2c is used
by a separate processor and using the SAI lines in  a different device
that runs linux will work. Kindly advice
To support that, you will have to write your own card driver or at least
write a device tree sound node with a dummy codec as Linux will not be
configuring it.

See https://bootlin.com/pub/conferences/2020/lee/belloni-alsa-asoc/belloni-alsa-asoc.pdf

--
Alexandre Belloni, co-owner and COO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


Amrun Nisha.R
 

Hi Alexandre,

Thanks for your guidance. I have updated my device tree with dummy codec as linux. Still the sound card is not properly added. When i tried to verify that using aplay, i got error message as "no sound card is found". Kindly advice.