Problem in running poky-qemu


sachin
 

Dear All:

I am new to qemu, so please excuse me, i am asking basic question.

Actually i want to run linux image for ppc on qemu.

My host machine is running Fedora13.

For that i have downloaded following from yocto project website.

Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2

Now toolchain was installed properly.

Now when i am running poky-qemu from command line it is giving following message
=============================================================================================
[root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script

=============================================================================================
I am blank about this message, which script they are referring.
Please help me for the same.
This will be a great help for me as i am at critical phase of one of my project.

Kind Regards
Sachin





Zhang, Jessica
 

Hi Sachin,
 
First of all, if you want to run ppc, the toolchain you need to download is yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2.  After you install it under /opt/poky, you should go under /opt/poky and source the environment-setup-ppc* and try start qemu again...
 
Let us know if you still run into issues.
 
Thanks,
Jessica



From: yocto-bounces@... [mailto:yocto-bounces@...] On Behalf Of sachin kumar
Sent: Wednesday, November 10, 2010 6:09 PM
To: yocto@...
Subject: [yocto] Problem in running poky-qemu

Dear All:

I am new to qemu, so please excuse me, i am asking basic question.

Actually i want to run linux image for ppc on qemu.

My host machine is running Fedora13.

For that i have downloaded following from yocto project website.

Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2

Now toolchain was installed properly.

Now when i am running poky-qemu from command line it is giving following message
=============================================================================================
[root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script

=============================================================================================
I am blank about this message, which script they are referring.
Please help me for the same.
This will be a great help for me as i am at critical phase of one of my project.

Kind Regards
Sachin





Scott Garman <scott.a.garman@...>
 

On 11/10/2010 06:08 PM, sachin kumar wrote:
Dear All:

I am new to qemu, so please excuse me, i am asking basic question.

Actually i want to run linux image for ppc on qemu.

My host machine is running Fedora13.

For that i have downloaded following from yocto project website.

Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2

Now toolchain was installed properly.

Now when i am running poky-qemu from command line it is giving following
message
=============================================================================================
[root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin
yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script

=============================================================================================
I am blank about this message, which script they are referring.
Hi Sachin,

When you installed the toolchain tarball (yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2), it should have created a script /opt/poky/environment-setup-<arch>. That's the one you want to source.

The other issue is that we changed the naming conventions of the kernel and qemu images at the last minute, and the poky-qemu script needs some additional help to figure out which machine architecture you're using and the format of the image. So you need to add "qemuppc" and "ext3" to the list of options to poky-qemu.

$ source /opt/poky/environment-setup-ppc603e-poky-linux
$ poky-qemu qemuppc zImage-2.6.34-qemuppc-0.9.bin yocto-image-minimal-qemuppc-0.9.rootfs.ext3 ext3

should get you going.

This needs to get fixed ASAP and I'm going to submit a patch for it tomorrow in master. Thanks for your patience.

Scott


sachin
 

Hello Jessica:

Thanks for your swift response, as per your suggestions i have downloaded yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2 file from yocto website.
I have installed the same.
you can see now content of my /opt/poky folder as following

[sachin@sachinlinux yocto_tools]$ ls /opt/poky/
environment-setup-i586-poky-linux     site-config-i586-poky-linux     sysroots                 version-ppc603e-poky-linux
environment-setup-ppc603e-poky-linux  site-config-ppc603e-poky-linux  version-i586-poky-linux
[sachin@sachinlinux yocto_tools]$

But despite that i am getting same message

[sachin@sachinlinux yocto_tools]$ poky-qemu zImage-2.6.34-qemuppc-0.9.bin yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script
[sachin@sachinlinux yocto_tools]$


I do not which script this is referring.
Please help me.

Kind regards

Sachin




On Thu, Nov 11, 2010 at 7:59 AM, Zhang, Jessica <jessica.zhang@...> wrote:
Hi Sachin,
 
First of all, if you want to run ppc, the toolchain you need to download is yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2.  After you install it under /opt/poky, you should go under /opt/poky and source the environment-setup-ppc* and try start qemu again...
 
Let us know if you still run into issues.
 
Thanks,
Jessica


From: yocto-bounces@... [mailto:yocto-bounces@...] On Behalf Of sachin kumar
Sent: Wednesday, November 10, 2010 6:09 PM
To: yocto@...
Subject: [yocto] Problem in running poky-qemu

Dear All:

I am new to qemu, so please excuse me, i am asking basic question.

Actually i want to run linux image for ppc on qemu.

My host machine is running Fedora13.

For that i have downloaded following from yocto project website.

Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2

Now toolchain was installed properly.

Now when i am running poky-qemu from command line it is giving following message
=============================================================================================
[root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script

=============================================================================================
I am blank about this message, which script they are referring.
Please help me for the same.
This will be a great help for me as i am at critical phase of one of my project.

Kind Regards
Sachin






Zhang, Jessica
 

Hi Sachin,
 
under /opt/poky, can you do the following in exact sequence:
1. source environment-setup-ppc603e-poky-linux
2. poky-qemy qemuppc zImage-2.6.34.qemuppc-0.9.bin yocto-image-minimal-qemuppc-0.9.rootfs.ext3
 
Thanks,
Jessica



From: sachindhiman123@... [mailto:sachindhiman123@...] On Behalf Of sachin kumar
Sent: Thursday, November 11, 2010 8:19 AM
To: Zhang, Jessica
Cc: yocto@...
Subject: Re: [yocto] Problem in running poky-qemu

Hello Jessica:

Thanks for your swift response, as per your suggestions i have downloaded yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2 file from yocto website.
I have installed the same.
you can see now content of my /opt/poky folder as following

[sachin@sachinlinux yocto_tools]$ ls /opt/poky/
environment-setup-i586-poky-linux     site-config-i586-poky-linux     sysroots                 version-ppc603e-poky-linux
environment-setup-ppc603e-poky-linux  site-config-ppc603e-poky-linux  version-i586-poky-linux
[sachin@sachinlinux yocto_tools]$

But despite that i am getting same message

[sachin@sachinlinux yocto_tools]$ poky-qemu zImage-2.6.34-qemuppc-0.9.bin yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script
[sachin@sachinlinux yocto_tools]$


I do not which script this is referring.
Please help me.

Kind regards

Sachin




On Thu, Nov 11, 2010 at 7:59 AM, Zhang, Jessica <jessica.zhang@...> wrote:
Hi Sachin,
 
First of all, if you want to run ppc, the toolchain you need to download is yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2.  After you install it under /opt/poky, you should go under /opt/poky and source the environment-setup-ppc* and try start qemu again...
 
Let us know if you still run into issues.
 
Thanks,
Jessica


From: yocto-bounces@... [mailto:yocto-bounces@...] On Behalf Of sachin kumar
Sent: Wednesday, November 10, 2010 6:09 PM
To: yocto@...
Subject: [yocto] Problem in running poky-qemu

Dear All:

I am new to qemu, so please excuse me, i am asking basic question.

Actually i want to run linux image for ppc on qemu.

My host machine is running Fedora13.

For that i have downloaded following from yocto project website.

Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2

Now toolchain was installed properly.

Now when i am running poky-qemu from command line it is giving following message
=============================================================================================
[root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script

=============================================================================================
I am blank about this message, which script they are referring.
Please help me for the same.
This will be a great help for me as i am at critical phase of one of my project.

Kind Regards
Sachin






sachin
 

Hi:

i am sorry, again i am getting same message.

Regards
Sachin

On 11/12/10, Zhang, Jessica <jessica.zhang@intel.com> wrote:
Hi Sachin,

under /opt/poky, can you do the following in exact sequence:
1. source environment-setup-ppc603e-poky-linux
2. poky-qemy qemuppc zImage-2.6.34.qemuppc-0.9.bin
yocto-image-minimal-qemuppc-0.9.rootfs.ext3

Thanks,
Jessica

_____

From: sachindhiman123@gmail.com [mailto:sachindhiman123@gmail.com] On Behalf
Of sachin kumar
Sent: Thursday, November 11, 2010 8:19 AM
To: Zhang, Jessica
Cc: yocto@yoctoproject.org
Subject: Re: [yocto] Problem in running poky-qemu


Hello Jessica:

Thanks for your swift response, as per your suggestions i have downloaded
yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2 file from yocto website.
I have installed the same.
you can see now content of my /opt/poky folder as following

[sachin@sachinlinux yocto_tools]$ ls /opt/poky/
environment-setup-i586-poky-linux site-config-i586-poky-linux
sysroots version-ppc603e-poky-linux
environment-setup-ppc603e-poky-linux site-config-ppc603e-poky-linux
version-i586-poky-linux
[sachin@sachinlinux yocto_tools]$

But despite that i am getting same message

[sachin@sachinlinux yocto_tools]$ poky-qemu zImage-2.6.34-qemuppc-0.9.bin
yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script
[sachin@sachinlinux yocto_tools]$


I do not which script this is referring.
Please help me.

Kind regards

Sachin





On Thu, Nov 11, 2010 at 7:59 AM, Zhang, Jessica <jessica.zhang@intel.com>
wrote:


Hi Sachin,

First of all, if you want to run ppc, the toolchain you need to download is
yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2. After you install it
under /opt/poky, you should go under /opt/poky and source the
environment-setup-ppc* and try start qemu again...

Let us know if you still run into issues.

Thanks,
Jessica

_____

From: yocto-bounces@yoctoproject.org [mailto:yocto-bounces@yoctoproject.org]
On Behalf Of sachin kumar
Sent: Wednesday, November 10, 2010 6:09 PM
To: yocto@yoctoproject.org
Subject: [yocto] Problem in running poky-qemu


Dear All:

I am new to qemu, so please excuse me, i am asking basic question.

Actually i want to run linux image for ppc on qemu.

My host machine is running Fedora13.

For that i have downloaded following from yocto project website.

Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2

Now toolchain was installed properly.

Now when i am running poky-qemu from command line it is giving following
message
============================================================================
=================
[root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin
yocto-image-minimal-qemuppc-0.9.rootfs.ext3
Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script

============================================================================
=================
I am blank about this message, which script they are referring.
Please help me for the same.
This will be a great help for me as i am at critical phase of one of my
project.

Kind Regards
Sachin








Scott Garman <scott.a.garman@...>
 

On 11/12/2010 03:31 AM, sachin kumar wrote:
Hi:

i am sorry, again i am getting same message.
Sachin,

Please also see my reply to this thread. Try adding both "qemuppc" and "ext3" to the list of options you're passing to poky-qemu. I was able to reproduce your problem and workaround it by adding those two options.

Scott

--
Scott Garman
Embedded Linux Distro Engineer - Yocto Project


sachin dhiman <sachindhiman123@...>
 

Dear All:

Please help me, as i am still having same issue.


Kind Regards
Sachin


On Fri, Nov 12, 2010 at 5:01 PM, sachin kumar <sachinsomeone@...> wrote:
Hi:

i am sorry, again i am getting same message.

Regards
Sachin

On 11/12/10, Zhang, Jessica <jessica.zhang@...> wrote:
> Hi Sachin,
>
> under /opt/poky, can you do the following in exact sequence:
> 1. source environment-setup-ppc603e-poky-linux
> 2. poky-qemy qemuppc zImage-2.6.34.qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
>
> Thanks,
> Jessica
>
>   _____
>
> From: sachindhiman123@... [mailto:sachindhiman123@...] On Behalf
> Of sachin kumar
> Sent: Thursday, November 11, 2010 8:19 AM
> To: Zhang, Jessica
> Cc: yocto@...
> Subject: Re: [yocto] Problem in running poky-qemu
>
>
> Hello Jessica:
>
> Thanks for your swift response, as per your suggestions i have downloaded
> yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2 file from yocto website.
> I have installed the same.
> you can see now content of my /opt/poky folder as following
>
> [sachin@sachinlinux yocto_tools]$ ls /opt/poky/
> environment-setup-i586-poky-linux     site-config-i586-poky-linux
> sysroots                 version-ppc603e-poky-linux
> environment-setup-ppc603e-poky-linux  site-config-ppc603e-poky-linux
> version-i586-poky-linux
> [sachin@sachinlinux yocto_tools]$
>
> But despite that i am getting same message
>
> [sachin@sachinlinux yocto_tools]$ poky-qemu zImage-2.6.34-qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
> In order for this script to dynamically infer paths
> to kernels or filesystem images, you either need
> bitbake in your PATH or to source poky-init-build-env
> before running this script
> [sachin@sachinlinux yocto_tools]$
>
>
> I do not which script this is referring.
> Please help me.
>
> Kind regards
>
> Sachin
>
>
>
>
>
> On Thu, Nov 11, 2010 at 7:59 AM, Zhang, Jessica <jessica.zhang@...>
> wrote:
>
>
> Hi Sachin,
>
> First of all, if you want to run ppc, the toolchain you need to download is
> yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2.  After you install it
> under /opt/poky, you should go under /opt/poky and source the
> environment-setup-ppc* and try start qemu again...
>
> Let us know if you still run into issues.
>
> Thanks,
> Jessica
>
>   _____
>
> From: yocto-bounces@... [mailto:yocto-bounces@...]
> On Behalf Of sachin kumar
> Sent: Wednesday, November 10, 2010 6:09 PM
> To: yocto@...
> Subject: [yocto] Problem in running poky-qemu
>
>
> Dear All:
>
> I am new to qemu, so please excuse me, i am asking basic question.
>
> Actually i want to run linux image for ppc on qemu.
>
> My host machine is running Fedora13.
>
> For that i have downloaded following from yocto project website.
>
> Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
> Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2
>
> Now toolchain was installed properly.
>
> Now when i am running poky-qemu from command line it is giving following
> message
> ============================================================================
> =================
> [root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
> In order for this script to dynamically infer paths
> to kernels or filesystem images, you either need
> bitbake in your PATH or to source poky-init-build-env
> before running this script
>
> ============================================================================
> =================
> I am blank about this message, which script they are referring.
> Please help me for the same.
> This will be a great help for me as i am at critical phase of one of my
> project.
>
> Kind Regards
> Sachin
>
>
>
>
>
>
>
>


sachin
 

Please help me i am still having same issue.


On Fri, Nov 12, 2010 at 5:01 PM, sachin kumar <sachinsomeone@...> wrote:
Hi:

i am sorry, again i am getting same message.

Regards
Sachin

On 11/12/10, Zhang, Jessica <jessica.zhang@...> wrote:
> Hi Sachin,
>
> under /opt/poky, can you do the following in exact sequence:
> 1. source environment-setup-ppc603e-poky-linux
> 2. poky-qemy qemuppc zImage-2.6.34.qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
>
> Thanks,
> Jessica
>
>   _____
>
> From: sachindhiman123@... [mailto:sachindhiman123@...] On Behalf
> Of sachin kumar
> Sent: Thursday, November 11, 2010 8:19 AM
> To: Zhang, Jessica
> Cc: yocto@...
> Subject: Re: [yocto] Problem in running poky-qemu
>
>
> Hello Jessica:
>
> Thanks for your swift response, as per your suggestions i have downloaded
> yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2 file from yocto website.
> I have installed the same.
> you can see now content of my /opt/poky folder as following
>
> [sachin@sachinlinux yocto_tools]$ ls /opt/poky/
> environment-setup-i586-poky-linux     site-config-i586-poky-linux
> sysroots                 version-ppc603e-poky-linux
> environment-setup-ppc603e-poky-linux  site-config-ppc603e-poky-linux
> version-i586-poky-linux
> [sachin@sachinlinux yocto_tools]$
>
> But despite that i am getting same message
>
> [sachin@sachinlinux yocto_tools]$ poky-qemu zImage-2.6.34-qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
> In order for this script to dynamically infer paths
> to kernels or filesystem images, you either need
> bitbake in your PATH or to source poky-init-build-env
> before running this script
> [sachin@sachinlinux yocto_tools]$
>
>
> I do not which script this is referring.
> Please help me.
>
> Kind regards
>
> Sachin
>
>
>
>
>
> On Thu, Nov 11, 2010 at 7:59 AM, Zhang, Jessica <jessica.zhang@...>
> wrote:
>
>
> Hi Sachin,
>
> First of all, if you want to run ppc, the toolchain you need to download is
> yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2.  After you install it
> under /opt/poky, you should go under /opt/poky and source the
> environment-setup-ppc* and try start qemu again...
>
> Let us know if you still run into issues.
>
> Thanks,
> Jessica
>
>   _____
>
> From: yocto-bounces@... [mailto:yocto-bounces@...]
> On Behalf Of sachin kumar
> Sent: Wednesday, November 10, 2010 6:09 PM
> To: yocto@...
> Subject: [yocto] Problem in running poky-qemu
>
>
> Dear All:
>
> I am new to qemu, so please excuse me, i am asking basic question.
>
> Actually i want to run linux image for ppc on qemu.
>
> My host machine is running Fedora13.
>
> For that i have downloaded following from yocto project website.
>
> Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
> Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2
>
> Now toolchain was installed properly.
>
> Now when i am running poky-qemu from command line it is giving following
> message
> ============================================================================
> =================
> [root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
> In order for this script to dynamically infer paths
> to kernels or filesystem images, you either need
> bitbake in your PATH or to source poky-init-build-env
> before running this script
>
> ============================================================================
> =================
> I am blank about this message, which script they are referring.
> Please help me for the same.
> This will be a great help for me as i am at critical phase of one of my
> project.
>
> Kind Regards
> Sachin
>
>
>
>
>
>
>
>


Zhang, Jessica
 

Hmm, somehow had the impression that your issue is relsoved, if not, sorry for the delay on getting back to you...
 
under /opt/poky do...
 
 1. source environment-setup-ppc603e-poky-linux
2. poky-qemu qemuppc absolute-path/zImage-2.6.34.qemuppc-0.9.bin
 absolute-path/yocto-image-minimal-qemuppc-0.9.rootfs.ext3 ext3
 
Please note I've added the absolute path to your 2 qemu files if they're not under the directory that you invoke poky-qemu.  This should fix your problem.
 
Thanks,
Jessica



From: sachindhiman123@... [mailto:sachindhiman123@...] On Behalf Of sachin kumar
Sent: Wednesday, November 24, 2010 8:22 AM
To: Zhang, Jessica
Cc: yocto@...
Subject: Re: [yocto] Problem in running poky-qemu

Please help me i am still having same issue.


On Fri, Nov 12, 2010 at 5:01 PM, sachin kumar <sachinsomeone@...> wrote:
Hi:

i am sorry, again i am getting same message.

Regards
Sachin

On 11/12/10, Zhang, Jessica <jessica.zhang@...> wrote:
> Hi Sachin,
>
> under /opt/poky, can you do the following in exact sequence:
> 1. source environment-setup-ppc603e-poky-linux
> 2. poky-qemy qemuppc zImage-2.6.34.qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
>
> Thanks,
> Jessica
>
>   _____
>
> From: sachindhiman123@... [mailto:sachindhiman123@...] On Behalf
> Of sachin kumar
> Sent: Thursday, November 11, 2010 8:19 AM
> To: Zhang, Jessica
> Cc: yocto@...
> Subject: Re: [yocto] Problem in running poky-qemu
>
>
> Hello Jessica:
>
> Thanks for your swift response, as per your suggestions i have downloaded
> yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2 file from yocto website.
> I have installed the same.
> you can see now content of my /opt/poky folder as following
>
> [sachin@sachinlinux yocto_tools]$ ls /opt/poky/
> environment-setup-i586-poky-linux     site-config-i586-poky-linux
> sysroots                 version-ppc603e-poky-linux
> environment-setup-ppc603e-poky-linux  site-config-ppc603e-poky-linux
> version-i586-poky-linux
> [sachin@sachinlinux yocto_tools]$
>
> But despite that i am getting same message
>
> [sachin@sachinlinux yocto_tools]$ poky-qemu zImage-2.6.34-qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
> In order for this script to dynamically infer paths
> to kernels or filesystem images, you either need
> bitbake in your PATH or to source poky-init-build-env
> before running this script
> [sachin@sachinlinux yocto_tools]$
>
>
> I do not which script this is referring.
> Please help me.
>
> Kind regards
>
> Sachin
>
>
>
>
>
> On Thu, Nov 11, 2010 at 7:59 AM, Zhang, Jessica <jessica.zhang@...>
> wrote:
>
>
> Hi Sachin,
>
> First of all, if you want to run ppc, the toolchain you need to download is
> yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2.  After you install it
> under /opt/poky, you should go under /opt/poky and source the
> environment-setup-ppc* and try start qemu again...
>
> Let us know if you still run into issues.
>
> Thanks,
> Jessica
>
>   _____
>
> From: yocto-bounces@... [mailto:yocto-bounces@...]
> On Behalf Of sachin kumar
> Sent: Wednesday, November 10, 2010 6:09 PM
> To: yocto@...
> Subject: [yocto] Problem in running poky-qemu
>
>
> Dear All:
>
> I am new to qemu, so please excuse me, i am asking basic question.
>
> Actually i want to run linux image for ppc on qemu.
>
> My host machine is running Fedora13.
>
> For that i have downloaded following from yocto project website.
>
> Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
> Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2
>
> Now toolchain was installed properly.
>
> Now when i am running poky-qemu from command line it is giving following
> message
> ============================================================================
> =================
> [root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
> In order for this script to dynamically infer paths
> to kernels or filesystem images, you either need
> bitbake in your PATH or to source poky-init-build-env
> before running this script
>
> ============================================================================
> =================
> I am blank about this message, which script they are referring.
> Please help me for the same.
> This will be a great help for me as i am at critical phase of one of my
> project.
>
> Kind Regards
> Sachin
>
>
>
>
>
>
>
>


sachin
 

Hi

I did same but still same problem.

I have also copied Disk "yocto-image-minimal-qemuppc-0.9.rootfs.ext3" and "Kernel Image : zImage-2.6.34-qemuppc-0.9.bin" in the /opt/poky directory


To run qemu i am using following commands


[sachin@sachinlinux poky]$ source environment-setup-ppc603e-poky-linux


[sachin@sachinlinux poky]$ poky-qemu qemuppc zImage-2.6.34-qemuppc-0.9.bin yocto-image-minimal-qemuppc-0.9.rootfs.ext3
In order for this script to dynamically infer paths
to kernels or filesystem images, you either need
bitbake in your PATH or to source poky-init-build-env
before running this script


So i am not able to run poky-qemu command.

Please suggest what to do next.

Kind Regards
Sachin


On Wed, Nov 24, 2010 at 10:58 PM, Zhang, Jessica <jessica.zhang@...> wrote:
Hmm, somehow had the impression that your issue is relsoved, if not, sorry for the delay on getting back to you...
 
under /opt/poky do...
 
 1. source environment-setup-ppc603e-poky-linux
2. poky-qemu qemuppc absolute-path/zImage-2.6.34.qemuppc-0.9.bin
 absolute-path/yocto-image-minimal-qemuppc-0.9.rootfs.ext3 ext3
 
Please note I've added the absolute path to your 2 qemu files if they're not under the directory that you invoke poky-qemu.  This should fix your problem.
 
Thanks,
Jessica



From: sachindhiman123@... [mailto:sachindhiman123@...] On Behalf Of sachin kumar
Sent: Wednesday, November 24, 2010 8:22 AM

To: Zhang, Jessica
Cc: yocto@...
Subject: Re: [yocto] Problem in running poky-qemu

Please help me i am still having same issue.


On Fri, Nov 12, 2010 at 5:01 PM, sachin kumar <sachinsomeone@...> wrote:
Hi:

i am sorry, again i am getting same message.

Regards
Sachin

On 11/12/10, Zhang, Jessica <jessica.zhang@...> wrote:
> Hi Sachin,
>
> under /opt/poky, can you do the following in exact sequence:
> 1. source environment-setup-ppc603e-poky-linux
> 2. poky-qemy qemuppc zImage-2.6.34.qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
>
> Thanks,
> Jessica
>
>   _____
>
> From: sachindhiman123@... [mailto:sachindhiman123@...] On Behalf
> Of sachin kumar
> Sent: Thursday, November 11, 2010 8:19 AM
> To: Zhang, Jessica
> Cc: yocto@...
> Subject: Re: [yocto] Problem in running poky-qemu
>
>
> Hello Jessica:
>
> Thanks for your swift response, as per your suggestions i have downloaded
> yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2 file from yocto website.
> I have installed the same.
> you can see now content of my /opt/poky folder as following
>
> [sachin@sachinlinux yocto_tools]$ ls /opt/poky/
> environment-setup-i586-poky-linux     site-config-i586-poky-linux
> sysroots                 version-ppc603e-poky-linux
> environment-setup-ppc603e-poky-linux  site-config-ppc603e-poky-linux
> version-i586-poky-linux
> [sachin@sachinlinux yocto_tools]$
>
> But despite that i am getting same message
>
> [sachin@sachinlinux yocto_tools]$ poky-qemu zImage-2.6.34-qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
> In order for this script to dynamically infer paths
> to kernels or filesystem images, you either need
> bitbake in your PATH or to source poky-init-build-env
> before running this script
> [sachin@sachinlinux yocto_tools]$
>
>
> I do not which script this is referring.
> Please help me.
>
> Kind regards
>
> Sachin
>
>
>
>
>
> On Thu, Nov 11, 2010 at 7:59 AM, Zhang, Jessica <jessica.zhang@...>
> wrote:
>
>
> Hi Sachin,
>
> First of all, if you want to run ppc, the toolchain you need to download is
> yocto-eglibc-i586-powerpc-toolchain-sdk-0.9.tar.bz2.  After you install it
> under /opt/poky, you should go under /opt/poky and source the
> environment-setup-ppc* and try start qemu again...
>
> Let us know if you still run into issues.
>
> Thanks,
> Jessica
>
>   _____
>
> From: yocto-bounces@... [mailto:yocto-bounces@...]
> On Behalf Of sachin kumar
> Sent: Wednesday, November 10, 2010 6:09 PM
> To: yocto@...
> Subject: [yocto] Problem in running poky-qemu
>
>
> Dear All:
>
> I am new to qemu, so please excuse me, i am asking basic question.
>
> Actually i want to run linux image for ppc on qemu.
>
> My host machine is running Fedora13.
>
> For that i have downloaded following from yocto project website.
>
> Disk Image: yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Kernel Image : zImage-2.6.34-qemuppc-0.9.bin
> Toolchain: yocto-eglibc-i586-i586-toolchain-sdk-0.9.tar.bz2
>
> Now toolchain was installed properly.
>
> Now when i am running poky-qemu from command line it is giving following
> message
> ============================================================================
> =================
> [root@sachinlinux yocto_tools]# poky-qemu zImage-2.6.34-qemuppc-0.9.bin
> yocto-image-minimal-qemuppc-0.9.rootfs.ext3
> Set MACHINE to [qemuppc-0] based on kernel [zImage-2.6.34-qemuppc-0.9.bin]
> In order for this script to dynamically infer paths
> to kernels or filesystem images, you either need
> bitbake in your PATH or to source poky-init-build-env
> before running this script
>
> ============================================================================
> =================
> I am blank about this message, which script they are referring.
> Please help me for the same.
> This will be a great help for me as i am at critical phase of one of my
> project.
>
> Kind Regards
> Sachin
>
>
>
>
>
>
>
>