[meta-security][PATCH] clamav: add COMPATIBLE_HOST to fix build error


Davide Gardenal
 

Add COMPATIBLE_HOST to match what is found in glibc
to avoid build error when using musl

Signed-off-by: Davide Gardenal <davide.gardenal@...>
---
recipes-scanners/clamav/clamav_0.104.0.bb | 2 ++
1 file changed, 2 insertions(+)

diff --git a/recipes-scanners/clamav/clamav_0.104.0.bb b/recipes-scanners/clamav/clamav_0.104.0.bb
index f0889de..ae2d292 100644
--- a/recipes-scanners/clamav/clamav_0.104.0.bb
+++ b/recipes-scanners/clamav/clamav_0.104.0.bb
@@ -6,6 +6,8 @@ LICENSE = "LGPL-2.1"

DEPENDS = "glibc llvm libtool db openssl zlib curl libxml2 bison pcre2 json-c libcheck"

+COMPATIBLE_HOST:libc-musl:class-target = "null"
+
LIC_FILES_CHKSUM = "file://COPYING.txt;beginline=2;endline=3;md5=f7029fbbc5898b273d5902896f7bbe17"

# July 27th
--
2.32.0


Armin Kuster
 

merged.

thanks
-armin

On 4/4/22 05:57, Davide Gardenal wrote:
Add COMPATIBLE_HOST to match what is found in glibc
to avoid build error when using musl

Signed-off-by: Davide Gardenal <davide.gardenal@...>
---
recipes-scanners/clamav/clamav_0.104.0.bb | 2 ++
1 file changed, 2 insertions(+)

diff --git a/recipes-scanners/clamav/clamav_0.104.0.bb b/recipes-scanners/clamav/clamav_0.104.0.bb
index f0889de..ae2d292 100644
--- a/recipes-scanners/clamav/clamav_0.104.0.bb
+++ b/recipes-scanners/clamav/clamav_0.104.0.bb
@@ -6,6 +6,8 @@ LICENSE = "LGPL-2.1"
DEPENDS = "glibc llvm libtool db openssl zlib curl libxml2 bison pcre2 json-c libcheck"
+COMPATIBLE_HOST:libc-musl:class-target = "null"
+
LIC_FILES_CHKSUM = "file://COPYING.txt;beginline=2;endline=3;md5=f7029fbbc5898b273d5902896f7bbe17"
# July 27th