[meta-oracle-java][PATCH 4/6] oracle-jse: update dependency from gtk+ to gtk+3


Roland Hieber
 

GTK+ 2 is deprecated, and has not been included in OE-Core since commit
3c692e0d77e68908ab0e (2019-07-05, Ross Burton: "gtk+: remove GTK+ 2").
Java SE also builds with GTK+ 3, so update the dependency.

Link: https://github.com/openembedded/openembedded-core/commit/3c692e0d77e68908ab0e
Signed-off-by: Roland Hieber <rhi@...>
---
recipes-devtools/oracle-java/oracle-jse.inc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/recipes-devtools/oracle-java/oracle-jse.inc b/recipes-devtools/oracle-java/oracle-jse.inc
index ce8280c8cb51..c799c03033c6 100644
--- a/recipes-devtools/oracle-java/oracle-jse.inc
+++ b/recipes-devtools/oracle-java/oracle-jse.inc
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "\

FETCHCMD_wget_append = " --no-check-certificate --no-cookies --header 'Cookie: oraclelicense=accept-securebackup-cookie' "

-RDEPENDS_${PN} += " libasound atk cairo gdk-pixbuf mesa gtk+ libxtst libxi"
+RDEPENDS_${PN} += " libasound atk cairo gdk-pixbuf mesa gtk+3 libxtst libxi"
# get the java update version in the resulting package
PR =. "u${PV_UPDATE}"
S = "${WORKDIR}"
--
2.30.2