[meta-gplv2] [PATCH] layer.conf: Delete as the layer is now officially obsolete and unmaintained


Richard Purdie
 

Remove the layer.conf as this layer is no longer being maintained and
we need to draw people's attention to that.

The software in this layer has not seen security fixes in a long time.
As such, nobody should be using it. There are other ways of removing GPLv3
components from modern OE/YP builds and we'd like to focus people's
attention onto those. If there are issues that current solutions can't
meet, we need to find new ways to address them, this layer isn't it.

We've talked about this layers maintenance for a long time on the mailing
lists and in weekly tech calls so this shouldn't surprise anyone.

Signed-off-by: Richard Purdie <richard.purdie@...>
---
conf/layer.conf | 23 -----------------------
1 file changed, 23 deletions(-)
delete mode 100644 conf/layer.conf

diff --git a/conf/layer.conf b/conf/layer.conf
deleted file mode 100644
index 48fc58f..0000000
--- a/conf/layer.conf
+++ /dev/null
@@ -1,23 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
-
-BBFILE_COLLECTIONS += "gplv2"
-BBFILE_PATTERN_gplv2 = "^${LAYERDIR}/"
-BBFILE_PRIORITY_gplv2 = "1"
-
-# This should only be incremented on significant changes that will
-# cause compatibility issues with other layers
-LAYERVERSION_gplv2 = "1"
-
-LAYERDEPENDS_gplv2 = "core"
-
-LAYERSERIES_COMPAT_gplv2 = "kirkstone"
-
-LICENSE_PATH += "${LAYERDIR}/licenses"
-
-PREFERRED_VERSION_elfutils = "${@['', '0.148']['GPLV3' in (d.getVar('INCOMPATIBLE_LICENSE') or '').upper()]}"
-PREFERRED_VERSION_shared-mime-info = "${@['', '1.10']['GPLV3' in (d.getVar('INCOMPATIBLE_LICENSE') or '').upper()]}"
-PREFERRED_VERSION_shared-mime-info-native = "${@['', '1.10']['GPLV3' in (d.getVar('INCOMPATIBLE_LICENSE') or '').upper()]}"
--
2.34.1