libmodulemd ver downgraded worrior->dunfell


Yair
 

When comparing Worrior and Dunfell trees, the early one uses libmodulemd ver 2.1.0, while the latter uses libmodulemd-v1 (1.8.16).

What's the reason for this downgrade?

Yair


Quentin Schulz
 

Hi Yair,

On 5/11/22 11:07, Yair via lists.yoctoproject.org wrote:
When comparing Worrior and Dunfell trees, the early one uses libmodulemd ver 2.1.0, while the latter uses libmodulemd-v1 (1.8.16).
What's the reason for this downgrade?
https://cgit.openembedded.org/openembedded-core/commit/meta/recipes-devtools/libmodulemd?h=dunfell&id=e0678765b1fb66df6ec37da1d32836bee2237af1
https://cgit.openembedded.org/openembedded-core/commit/meta/recipes-devtools/libmodulemd?h=dunfell&id=e5bf0814f565458c1c13d305dfc80a70a060555e

Gatesgarth and later use libmodulemd ver 2+ again,
https://cgit.openembedded.org/openembedded-core/commit/meta/recipes-devtools/libmodulemd?h=gatesgarth&id=2c518de672d8876ff96e49b498feb898a497e6a5

Feel free to just add the libmodulemd_git.bb recipe again in your own layer.

Cheers,
Quentin