Topics

cpio issues


Damien LEFEVRE
 

Hi,

I am working with Tegra Xavier and meta-tegra.

During the build process, 2 images get generated:
 - initramfs (cpio archive)
 - the actual roofs image

initramfs is archived with cpio and since the cpio image type is enabled, bitbake tries to cpio the rootfs. The roofts is more than 2GB (not difficult with CUDA libraries) and cpio fails due to some 2GB size limitation.

How can I keep the initramfs with cpio, but disable cpio archiving for the rootfs which I don't need or use for anything?

Thanks,
-Damien


Leon Woestenberg
 

Hello Damien,

On Fri, Jan 15, 2021 at 3:48 PM Damien LEFEVRE <lefevre.da@gmail.com> wrote:

How can I keep the initramfs with cpio, but disable cpio archiving for the rootfs which I don't need or use for anything?
I have this in my local.conf:

IMAGE_FSTYPES = "tar ext4"
INITRAMFS_FSTYPES = "cpio.xz"

It does depend a bit on your image recipes and classes if this works for you.

Regards,

Leon.