Changing git url of qemu


Edgar Mobile
 

Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Alexander Kanavin
 

You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:
Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.




Edgar Mobile
 

I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.

Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:
Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Alexander Kanavin
 

I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:
I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:
You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:
Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:
I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:
You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:
Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Alexander Kanavin
 

I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:

I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:

I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:

Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

I now have

-Dvulkan-drivers=swrast,virtio-experimental

In mesa_22.2.0.bb doesn't help

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:

I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:

I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:

Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:

I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:

I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:

Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Alexander Kanavin
 

The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:

Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:


I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:


I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:


Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
________________________________
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]
________________________________
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:

Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:


I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:


I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:


Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Alexander Kanavin
 

Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:

Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:


Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:



I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:



I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:



Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
________________________________
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]
________________________________

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

Tried building mesa on its own with the recipe changes. It fails with meson Error this is a bug and should be reported.

Am 28. September 2022 13:37:05 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:

Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:


Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:



I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:



I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:



Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

Tried in a sifferent machine with wednesday poky master

Building mesa-native gives the error

cp: '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' and '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' are the same file

Am 28. September 2022 13:37:05 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:

Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:


Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:



I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:



I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:



Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Alexander Kanavin
 

You need to build mesa, not mesa-native. And please show exact changes you made.

Alex

On Thu 29. Sep 2022 at 12.28, PHIL <heideggm@...> wrote:
Tried in a sifferent machine with wednesday poky master

Building mesa-native gives the error

cp: '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' and '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' are the same file


Am 28. September 2022 13:37:05 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:
Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:

Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:


Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:



I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:



I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:



Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index 8a74e0a80a..ffa35a5ca7 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):
 
 PACKAGECONFIG = " \
        gallium \
+       gallium-llvm \
        ${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
        ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl gles gbm virgl', '', d)} \
        ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled, -Ddri3=disabled, xorgproto libxshmfence"
 
 # Vulkan drivers need dri3 enabled
 # amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
 VULKAN_DRIVERS:append:x86:class-target = ",intel"
 VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
 VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG', 'freedreno', ',freedreno', '', d)}"
diff --git a/meta/recipes-graphics/mesa/mesa_22.2.0.bb b/meta/recipes-graphics/mesa/mesa_22.2.0.bb
index 96e8aa38d6..81b1cd66fd 100644
--- a/meta/recipes-graphics/mesa/mesa_22.2.0.bb
+++ b/meta/recipes-graphics/mesa/mesa_22.2.0.bb
@@ -1,2 +1,6 @@
 require ${BPN}.inc
 
+
+EXTRA_OEMESON += "-Dvulkan-drivers=virtio-experimental"
+
+
diff --git a/meta/recipes-graphics/virglrenderer/virglrenderer_0.10.3.bb b/meta/recipes-graphics/virglrenderer/virglrenderer_0.10.3.bb
index 3480eb954d..9760d86cf9 100644
--- a/meta/recipes-graphics/virglrenderer/virglrenderer_0.10.3.bb
+++ b/meta/recipes-graphics/virglrenderer/virglrenderer_0.10.3.bb
@@ -31,3 +31,5 @@ PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,libcheck"
 BBCLASSEXTEND = "native nativesdk"
 
 REQUIRED_DISTRO_FEATURES = "opengl"
+
+EXTRA_OEMESON += "-Dvenus-experimental=true"
/media/user/SSD1TB/yoctoqemu/poky master✭✱ ❯


From: Alexander Kanavin <alex.kanavin@...>
Sent: Thursday, September 29, 2022 10:46 AM
To: PHIL <heideggm@...>
Cc: Yocto-mailing-list <yocto@...>
Subject: Re: [yocto] Changing git url of qemu
 
You need to build mesa, not mesa-native. And please show exact changes you made.

Alex

On Thu 29. Sep 2022 at 12.28, PHIL <heideggm@...> wrote:

Tried in a sifferent machine with wednesday poky master

Building mesa-native gives the error

cp: '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' and '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' are the same file


Am 28. September 2022 13:37:05 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:
Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:

Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:


Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:



I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:



I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:



Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

I deleted the whole build directory, recreated it, only added the arm switch in local conf and your changes for mesa.inc.
After a few hours of building core-image-weston it again complains that it tries to copy llcm-config14.0.6 over itself. I don't know what to do anymore.


From: Alexander Kanavin <alex.kanavin@...>
Sent: Thursday, September 29, 2022 10:46 AM
To: PHIL <heideggm@...>
Cc: Yocto-mailing-list <yocto@...>
Subject: Re: [yocto] Changing git url of qemu
 
You need to build mesa, not mesa-native. And please show exact changes you made.

Alex

On Thu 29. Sep 2022 at 12.28, PHIL <heideggm@...> wrote:

Tried in a sifferent machine with wednesday poky master

Building mesa-native gives the error

cp: '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' and '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' are the same file


Am 28. September 2022 13:37:05 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:
Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:

Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:


Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:



I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:



I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:



Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Alexander Kanavin
 

You might want to try enabling gallium-llvm only for the target mesa:

PACKAGECONFIG:append:x86-64:pn-mesa = ' gallium-llvm'

Alex

On Fri, 30 Sept 2022 at 22:24, Edgar Mobile <heideggm@...> wrote:

I deleted the whole build directory, recreated it, only added the arm switch in local conf and your changes for mesa.inc.
After a few hours of building core-image-weston it again complains that it tries to copy llcm-config14.0.6 over itself. I don't know what to do anymore.

________________________________
From: Alexander Kanavin <alex.kanavin@...>
Sent: Thursday, September 29, 2022 10:46 AM
To: PHIL <heideggm@...>
Cc: Yocto-mailing-list <yocto@...>
Subject: Re: [yocto] Changing git url of qemu

You need to build mesa, not mesa-native. And please show exact changes you made.

Alex

On Thu 29. Sep 2022 at 12.28, PHIL <heideggm@...> wrote:

Tried in a sifferent machine with wednesday poky master

Building mesa-native gives the error

cp: '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' and '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' are the same file


Am 28. September 2022 13:37:05 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:


Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:



Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:




I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:




I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:




I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:




You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:




Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
________________________________
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]
________________________________



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.




--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

X86-64 is right or do you mean arm?

Am 30. September 2022 22:39:44 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

You might want to try enabling gallium-llvm only for the target mesa:

PACKAGECONFIG:append:x86-64:pn-mesa = ' gallium-llvm'

Alex

On Fri, 30 Sept 2022 at 22:24, Edgar Mobile <heideggm@...> wrote:

I deleted the whole build directory, recreated it, only added the arm switch in local conf and your changes for mesa.inc.
After a few hours of building core-image-weston it again complains that it tries to copy llcm-config14.0.6 over itself. I don't know what to do anymore.
From: Alexander Kanavin <alex.kanavin@...>
Sent: Thursday, September 29, 2022 10:46 AM
To: PHIL <heideggm@...>
Cc: Yocto-mailing-list <yocto@...>
Subject: Re: [yocto] Changing git url of qemu

You need to build mesa, not mesa-native. And please show exact changes you made.

Alex

On Thu 29. Sep 2022 at 12.28, PHIL <heideggm@...> wrote:

Tried in a sifferent machine with wednesday poky master

Building mesa-native gives the error

cp: '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' and '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' are the same file


Am 28. September 2022 13:37:05 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:


Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:



Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:




I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:




I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:




I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:




You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:




Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.




--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Alexander Kanavin
 

That depends on what is your target. If you're running qemu on a x86
host, it's better to not do software emulation and build for
qemux86_64 as well, and then run qemu with kvm, so it executes
directly on the host CPU.

Alex

On Fri, 30 Sept 2022 at 22:50, PHIL <heideggm@...> wrote:

X86-64 is right or do you mean arm?

Am 30. September 2022 22:39:44 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

You might want to try enabling gallium-llvm only for the target mesa:

PACKAGECONFIG:append:x86-64:pn-mesa = ' gallium-llvm'

Alex

On Fri, 30 Sept 2022 at 22:24, Edgar Mobile <heideggm@...> wrote:


I deleted the whole build directory, recreated it, only added the arm switch in local conf and your changes for mesa.inc.
After a few hours of building core-image-weston it again complains that it tries to copy llcm-config14.0.6 over itself. I don't know what to do anymore.
________________________________
From: Alexander Kanavin <alex.kanavin@...>
Sent: Thursday, September 29, 2022 10:46 AM
To: PHIL <heideggm@...>
Cc: Yocto-mailing-list <yocto@...>
Subject: Re: [yocto] Changing git url of qemu

You need to build mesa, not mesa-native. And please show exact changes you made.

Alex

On Thu 29. Sep 2022 at 12.28, PHIL <heideggm@...> wrote:

Tried in a sifferent machine with wednesday poky master

Building mesa-native gives the error

cp: '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' and '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' are the same file


Am 28. September 2022 13:37:05 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:


Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:



Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:




I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:




I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:




I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:




You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:




Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
________________________________
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]
________________________________
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.




--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


Edgar Mobile
 

I added your line to mesa.inc now it complains over llvm disabled again.

Am 30. September 2022 22:39:44 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

You might want to try enabling gallium-llvm only for the target mesa:

PACKAGECONFIG:append:x86-64:pn-mesa = ' gallium-llvm'

Alex

On Fri, 30 Sept 2022 at 22:24, Edgar Mobile <heideggm@...> wrote:

I deleted the whole build directory, recreated it, only added the arm switch in local conf and your changes for mesa.inc.
After a few hours of building core-image-weston it again complains that it tries to copy llcm-config14.0.6 over itself. I don't know what to do anymore.
From: Alexander Kanavin <alex.kanavin@...>
Sent: Thursday, September 29, 2022 10:46 AM
To: PHIL <heideggm@...>
Cc: Yocto-mailing-list <yocto@...>
Subject: Re: [yocto] Changing git url of qemu

You need to build mesa, not mesa-native. And please show exact changes you made.

Alex

On Thu 29. Sep 2022 at 12.28, PHIL <heideggm@...> wrote:

Tried in a sifferent machine with wednesday poky master

Building mesa-native gives the error

cp: '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' and '/media/user/SSD1TB/yoctoqemu/poky/build-virgl/tmp/work/x86_64-linux/mesa-native/2_22.2.0-r0/recipe-sysroot-native/usr/bin/llvm-config14.0.6' are the same file


Am 28. September 2022 13:37:05 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

Try latest poky master?

Alex

On Wed, 28 Sept 2022 at 13:23, PHIL <heideggm@...> wrote:


Mesa build fails. It complains that it copies llvm-config14.0.6 to the same file.

Am 28. September 2022 12:48:04 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


The following works for me. I get

tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_intel.so
tmp/work/core2-64-poky-linux/mesa/2_22.2.0-r0/packages-split/mesa-vulkan-drivers/usr/lib/libvulkan_lvp.so

--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -88,6 +88,7 @@ def strip_comma(s):

PACKAGECONFIG = " \
gallium \
+ gallium-llvm \
${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl
gles gbm virgl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
@@ -108,7 +109,7 @@ PACKAGECONFIG[dri3] = "-Ddri3=enabled,
-Ddri3=disabled, xorgproto libxshmfence"

# Vulkan drivers need dri3 enabled
# amd could be enabled as well but requires gallium-llvm with llvm >= 3.9
-VULKAN_DRIVERS = ""
+VULKAN_DRIVERS = "swrast"
VULKAN_DRIVERS:append:x86:class-target = ",intel"
VULKAN_DRIVERS:append:x86-64:class-target = ",intel"
VULKAN_DRIVERS:append ="${@bb.utils.contains('PACKAGECONFIG',
'freedreno', ',freedreno', '', d)}"

Alex

On Wed, 28 Sept 2022 at 11:49, PHIL <heideggm@...> wrote:



Also vulkan-drivers is empty in meson generated by bitbake. If I add it manually it will complain that llvm is disabled. How would I enable it?

Am 28. September 2022 10:51:26 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



I think for software vulkan you need to pass in
-Dvulkan-drivers=swrast when building mesa for the target.

Alex

On Wed, 28 Sept 2022 at 10:44, PHIL <heideggm@...> wrote:




I asked the author so I assume he would have told me. Apparently the virglrenderer branch is obsolete.

Currently my only changes from poky master are adding vulkan opengl x11 to distro features and vulkan-samples vulkan-loader vulkan-tools virglrenderer to core image extra install in local.conf.

I also added virtio-experimental flag to mesa and virglrenderer meson recipes.

I still get ERROR_INCOMPATIBLE_DRIVER when running vulkaninfo.

What am I missing for Software Mode?

Am 28. September 2022 10:29:28 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:




I would first check whether any of that work in the branch has meanwhile landed upstream. The post is from 2021.

Have you tried the software Vulkan in the guest?

Alex

On Wed 28. Sep 2022 at 10.21, PHIL <heideggm@...> wrote:




I try to enable vulkan according to this tutorial

https://www.collabora.com/news-and-blog/blog/2021/11/26/venus-on-qemu-enabling-new-virtual-vulkan-driver/

According to the author the modified qemu branch is still necessary so I want to enable that.


Am 28. September 2022 10:14:24 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:




You need to clarify what you want to do exactly. Why can’t you use the existing recipe?

Alex

On Wed 28. Sep 2022 at 9.58, Edgar Mobile <heideggm@...> wrote:




Greetings,

I want to change the git repo url in order to test the Venus driver. Can someone tell me which variable in which recipe I'd have to set?

Regards
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
Links: You receive all messages sent to this group.
View/Reply Online (#58196): https://lists.yoctoproject.org/g/yocto/message/58196
Mute This Topic: https://lists.yoctoproject.org/mt/93968127/1686489
Group Owner: yocto+owner@...
Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [alex.kanavin@...]
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.




--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.