Topics

Architecture did not match #yocto


Velumani, Yuvaraj
 

Hi All, 

I am getting error while building google chromium depot-tools. My intentions is to build meta-flutter which depends on depot-tools.

ERROR: depot-tools-git-r0 do_package_qa: QA Issue: Architecture did not match (x86-64, expected AArch64) on /work/aarch64-oe-linux/depot-tools/git-r0/packages-split/depot-tools-dev/usr/bin/depot_tools/ninja-linux64
Architecture did not match (x86, expected AArch64) on /work/aarch64-oe-linux/depot-tools/git-r0/packages-split/depot-tools-dev/usr/bin/depot_tools/ninja-linux32 [arch]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libc.so.6(GLIBC_2.4), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libc.so.6, but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libgcc_s.so.1(GLIBC_2.0), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/recipes/recipe_modules/gsutil/resources/gsutil_smart_retry.py contained in package depot-tools-dev requires /usr/bin/python, but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libc.so.6(GLIBC_2.2), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libc.so.6(GLIBC_2.1), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libstdc++.so.6, but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libstdc++.so.6(CXXABI_1.3), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux64 contained in package depot-tools-dev requires libc.so.6(GLIBC_2.2.5)(64bit), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/bootstrap/profile.d.python.sh contained in package depot-tools-dev requires /bin/bash, but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux64 contained in package depot-tools-dev requires libc.so.6(GLIBC_2.4)(64bit), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libm.so.6, but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libstdc++.so.6(GLIBCXX_3.4), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libc.so.6(GLIBC_2.1.3), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libc.so.6(GLIBC_2.0), but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA Issue: /usr/bin/depot_tools/ninja-linux32 contained in package depot-tools-dev requires libgcc_s.so.1, but no providers found in RDEPENDS_depot-tools-dev? [file-rdeps]
ERROR: depot-tools-git-r0 do_package_qa: QA run found fatal errors. Please consider fixing them.
ERROR: Logfile of failure stored in: /home/mio.ten.fujitsu.com/yvelumani/harmony/code/8155_agl/apps/apps_proc/poky/build/tmp-glibc/work/aarch64-oe-linux/depot-tools/git-r0/temp/log.do_package_qa.27049
ERROR: Task (/home/mio.ten.fujitsu.com/yvelumani/harmony/code/8155_agl/apps/apps_proc/meta-flutter/recipes-support/depot-tools/depot-tools_git.bb:do_package_qa) failed with exit code '1'
 
Thanks in Advance.


Ross Burton
 

On Fri, 20 Nov 2020 at 17:04, <yuvaraj.velumani@denso-ten.com> wrote:
I am getting error while building google chromium depot-tools. My intentions is to build meta-flutter which depends on depot-tools.

ERROR: depot-tools-git-r0 do_package_qa: QA Issue: Architecture did not match (x86-64, expected AArch64) on /work/aarch64-oe-linux/depot-tools/git-r0/packages-split/depot-tools-dev/usr/bin/depot_tools/ninja-linux64
Architecture did not match (x86, expected AArch64) on /work/aarch64-oe-linux/depot-tools/git-r0/packages-split/depot-tools-dev/usr/bin/depot_tools/ninja-linux32 [arch]
The recipe for depot-tools is broken and is building native code when
a target depot-tools should be x86-64.

Whilst that is a valid issue in the recipe, did you mean to build
depot-tools-native instead?

Ross