A bitbake error caused by "Variable BB_ENV_EXTRAWHITE" #bitbake


Yan Xinkuan
 

Hellow everyone, this is Yan. I am new to Yocto Project, still, I am learning.

There is a question, when I bitbaked my image I found this ERROR:

yanxk@yanxk-Ubuntu:~/Yocto/poky/build$ bitbake core-image-sato
ERROR: Variable BB_ENV_EXTRAWHITE has been renamed to BB_ENV_PASSTHROUGH_ADDITIONS
ERROR: Variable BB_ENV_EXTRAWHITE from the shell environment has been renamed to BB_ENV_PASSTHROUGH_ADDITIONS
ERROR: Exiting to allow enviroment variables to be corrected

How can I do a quick fix, and why is it working wrong?

By the way, I check the link https://git.openembedded.org/bitbake/commit/?id=87104b6a167188921da157c7dba45938849fb22a , which most likely the main cause.

Waiting for a help.


Alexander Kanavin
 

Hello,

you probably need to exit the shell and then restart it and
re-initialize your environment (with oe-init-build-env), as it
contains the obsolete variable.

Alex

On Sat, 13 Aug 2022 at 05:13, <lucky33newman@...> wrote:

Hellow everyone, this is Yan. I am new to Yocto Project, still, I am learning.

There is a question, when I bitbaked my image I found this ERROR:

yanxk@yanxk-Ubuntu:~/Yocto/poky/build$ bitbake core-image-sato
ERROR: Variable BB_ENV_EXTRAWHITE has been renamed to BB_ENV_PASSTHROUGH_ADDITIONS
ERROR: Variable BB_ENV_EXTRAWHITE from the shell environment has been renamed to BB_ENV_PASSTHROUGH_ADDITIONS
ERROR: Exiting to allow enviroment variables to be corrected

How can I do a quick fix, and why is it working wrong?

By the way, I check the link https://git.openembedded.org/bitbake/commit/?id=87104b6a167188921da157c7dba45938849fb22a , which most likely the main cause.

Waiting for a help.




Alexander Kanavin
 

Then you need to check the output of 'env'
a) when you start the shell
b) when you use oe-init-build-env
and figure out how the incorrect variable gets into the environment.
Are you using oe-init-build-env from an old yocto?

Alex

On Sat, 13 Aug 2022 at 15:02, Kaiwan N Billimoria
<kaiwan.billimoria@...> wrote:

Hello,
you probably need to exit the shell and then restart it and
re-initialize your environment (with oe-init-build-env), as it
contains the obsolete variable.
Alex
Hi,
I'm using the kirkstone release (4.0.2, Poky) and face the very same issue...
Exiting the shell and sourcing oe-init-build-env didn't help..

Any help is appreciated,

Thanks,
Kaiwan.

On Sat, 13 Aug 2022 at 05:13, <lucky33newman@...> wrote:

Hellow everyone, this is Yan. I am new to Yocto Project, still, I am learning.

There is a question, when I bitbaked my image I found this ERROR:

yanxk@yanxk-Ubuntu:~/Yocto/poky/build$ bitbake core-image-sato
ERROR: Variable BB_ENV_EXTRAWHITE has been renamed to BB_ENV_PASSTHROUGH_ADDITIONS
ERROR: Variable BB_ENV_EXTRAWHITE from the shell environment has been renamed to BB_ENV_PASSTHROUGH_ADDITIONS
ERROR: Exiting to allow enviroment variables to be corrected

How can I do a quick fix, and why is it working wrong?

By the way, I check the link https://git.openembedded.org/bitbake/commit/?id=87104b6a167188921da157c7dba45938849fb22a , which most likely the main cause.

Waiting for a help.