How to add INCOMPATIBLE_LICENSE only for one image? #bitbake #dunfell


Khem Raj
 

On 8/8/22 9:06 AM, Priyanshu Sharma wrote:
Hi,
I've two image recipes (foo.bb <http://foo.bb/> & bar.bb <http://bar.bb/>). I want to add INCOMPATIBLE_LICENSE="GPLv3" only in foo.bb <http://foo.bb/> & not bar.bb <http://bar.bb/>
Adding INCOMPATIBLE_LICENSE="GPLv3" in local.conf is applying it on both the images. So I tried this instead,
INCOMPATIBLE_LICENSE_pn-foo="GPLv3"
But this also isn't working. Is there any other way for this?
NOTE : The recipes are image recipes, not packages
Can you try something like this

INCOMPATIBLE_LICENSE:pn-foo = "GPL-3.0* LGPL-3.0*"

Cheers,
Priyanshu Sharma


Priyanshu Sharma
 

Hi,
 
I've two image recipes (foo.bb & bar.bb). I want to add INCOMPATIBLE_LICENSE="GPLv3" only in foo.bb & not bar.bb

Adding INCOMPATIBLE_LICENSE="GPLv3" in local.conf is applying it on both the images. So I tried this instead,

INCOMPATIBLE_LICENSE_pn-foo="GPLv3"
 
But this also isn't working. Is there any other way for this?
NOTE : The recipes are image recipes, not packages
 
Cheers,
Priyanshu Sharma