Customizing SERIAL_CONSOLES


chris yocto
 

I eventually fixed it by modifying /etc/inittab directly with ROOTFS_POSTPROCESS_COMMAND. This was the only way it worked.

Op do 14 jul. 2022 om 10:01 schreef chris yocto via lists.yoctoproject.org <chrisyocto2022=gmail.com@...>:

I did run bitbake with the -e option and it shows that it does process my machine extra config, but it's overriden by the conf of the BSP.  As a test I also added it to my layer.conf but this is also being overriden. I already set my layer too the highest priority.
How can I fix this?

SERIAL_CONSOLE=""
#
# $SERIAL_CONSOLES [7 operations]
#   set /home/chris/yocto/karo4/sources/meta-certhon/conf/layer.conf:14
#     "115200;ttymxc1"
#   set /home/chris/yocto/karo4/sources/meta-certhon/conf/machine/qs8m-mq00-extra.conf:1
#     "115200;ttymxc1"
#   set /home/chris/yocto/karo4/sources/meta-freescale/conf/machine/include/imx-base.inc:470
#     "115200;ttymxc0"
#   set /home/chris/yocto/karo4/sources/meta-karo-nxp/conf/machine/include/tx8m-base.inc:32
#     "115200;ttymxc2"
#   set /home/chris/yocto/karo4/sources/poky/meta/conf/documentation.conf:379
#     [doc] "Defines the serial consoles (TTYs) to enable using getty."
#   set /home/chris/yocto/karo4/sources/poky/meta/conf/bitbake.conf:856
#     [_defaultval] "${@d.getVar('SERIAL_CONSOLE').replace(' ', ';')}"
#   override[mxs]:set /home/chris/yocto/karo4/sources/meta-freescale/conf/machine/include/imx-base.inc:471
#     "115200;ttyAMA0"
# pre-expansion value:
#   "115200;ttymxc2"
SERIAL_CONSOLES="115200;ttymxc2"


Op di 12 jul. 2022 om 16:44 schreef Mike Looijmans <mike.looijmans@...>:
I'd suggest adding some "bogus" things to your machine-extra.conf,
because I don't think the file will actually be used (or even parsed)
anywhere.

You can override SERIAL_CONSOLES in your DISTRO config, as that takes
precedence over the machine config. In local.conf it won't work because
the MACHINE config is included after it.

Another approach is to grep on which recipes use it (half a dozen) and
then create a bbappend for each. That's the approach I've used recently.




Met vriendelijke groet / kind regards,

Mike Looijmans
System Expert


TOPIC Embedded Products B.V.
Materiaalweg 4, 5681 RJ Best
The Netherlands

T: +31 (0) 499 33 69 69
E: mike.looijmans@...
W: www.topic.nl

Please consider the environment before printing this e-mail
On 12-07-2022 13:41, chris yocto via lists.yoctoproject.org wrote:
>
> Hi,
>
> I’m trying to customize the SERIAL_CONSOLES variable. In another
> thread I read this can be done by adding a machine-extra.conf file too
> my custom layer. So I added “ SERIAL_CONSOLES = "115200;ttymxc0" ” to
> my machine-extra.conf, but when I  bitbake my custom image, no changes
> are found.
>
> In the conf file from the bsp for the board I’m using I found
> “SERIAL_CONSOLES = "115200;ttymxc2", when I change this to
> SERIAL_CONSOLES ?= "115200;ttymxc2" my changes are being applied.
>
> This off course is not ideal since I then still don’t have all changes
> in my own layer.
>
> Is there a way I can solve this?
>
> Kind regards,
>
> Chris
>
>
>
>

--
Mike Looijmans








chris yocto
 

I did run bitbake with the -e option and it shows that it does process my machine extra config, but it's overriden by the conf of the BSP.  As a test I also added it to my layer.conf but this is also being overriden. I already set my layer too the highest priority.
How can I fix this?

SERIAL_CONSOLE=""
#
# $SERIAL_CONSOLES [7 operations]
#   set /home/chris/yocto/karo4/sources/meta-certhon/conf/layer.conf:14
#     "115200;ttymxc1"
#   set /home/chris/yocto/karo4/sources/meta-certhon/conf/machine/qs8m-mq00-extra.conf:1
#     "115200;ttymxc1"
#   set /home/chris/yocto/karo4/sources/meta-freescale/conf/machine/include/imx-base.inc:470
#     "115200;ttymxc0"
#   set /home/chris/yocto/karo4/sources/meta-karo-nxp/conf/machine/include/tx8m-base.inc:32
#     "115200;ttymxc2"
#   set /home/chris/yocto/karo4/sources/poky/meta/conf/documentation.conf:379
#     [doc] "Defines the serial consoles (TTYs) to enable using getty."
#   set /home/chris/yocto/karo4/sources/poky/meta/conf/bitbake.conf:856
#     [_defaultval] "${@d.getVar('SERIAL_CONSOLE').replace(' ', ';')}"
#   override[mxs]:set /home/chris/yocto/karo4/sources/meta-freescale/conf/machine/include/imx-base.inc:471
#     "115200;ttyAMA0"
# pre-expansion value:
#   "115200;ttymxc2"
SERIAL_CONSOLES="115200;ttymxc2"


Op di 12 jul. 2022 om 16:44 schreef Mike Looijmans <mike.looijmans@...>:

I'd suggest adding some "bogus" things to your machine-extra.conf,
because I don't think the file will actually be used (or even parsed)
anywhere.

You can override SERIAL_CONSOLES in your DISTRO config, as that takes
precedence over the machine config. In local.conf it won't work because
the MACHINE config is included after it.

Another approach is to grep on which recipes use it (half a dozen) and
then create a bbappend for each. That's the approach I've used recently.




Met vriendelijke groet / kind regards,

Mike Looijmans
System Expert


TOPIC Embedded Products B.V.
Materiaalweg 4, 5681 RJ Best
The Netherlands

T: +31 (0) 499 33 69 69
E: mike.looijmans@...
W: www.topic.nl

Please consider the environment before printing this e-mail
On 12-07-2022 13:41, chris yocto via lists.yoctoproject.org wrote:
>
> Hi,
>
> I’m trying to customize the SERIAL_CONSOLES variable. In another
> thread I read this can be done by adding a machine-extra.conf file too
> my custom layer. So I added “ SERIAL_CONSOLES = "115200;ttymxc0" ” to
> my machine-extra.conf, but when I  bitbake my custom image, no changes
> are found.
>
> In the conf file from the bsp for the board I’m using I found
> “SERIAL_CONSOLES = "115200;ttymxc2", when I change this to
> SERIAL_CONSOLES ?= "115200;ttymxc2" my changes are being applied.
>
> This off course is not ideal since I then still don’t have all changes
> in my own layer.
>
> Is there a way I can solve this?
>
> Kind regards,
>
> Chris
>
>
>
>

--
Mike Looijmans





Mike Looijmans
 

I'd suggest adding some "bogus" things to your machine-extra.conf, because I don't think the file will actually be used (or even parsed) anywhere.

You can override SERIAL_CONSOLES in your DISTRO config, as that takes precedence over the machine config. In local.conf it won't work because the MACHINE config is included after it.

Another approach is to grep on which recipes use it (half a dozen) and then create a bbappend for each. That's the approach I've used recently.




Met vriendelijke groet / kind regards,

Mike Looijmans
System Expert


TOPIC Embedded Products B.V.
Materiaalweg 4, 5681 RJ Best
The Netherlands

T: +31 (0) 499 33 69 69
E: mike.looijmans@...
W: www.topic.nl

Please consider the environment before printing this e-mail

On 12-07-2022 13:41, chris yocto via lists.yoctoproject.org wrote:

Hi,

I’m trying to customize the SERIAL_CONSOLES variable. In another thread I read this can be done by adding a machine-extra.conf file too my custom layer. So I added “ SERIAL_CONSOLES = "115200;ttymxc0" ” to my machine-extra.conf, but when I  bitbake my custom image, no changes are found.

In the conf file from the bsp for the board I’m using I found “SERIAL_CONSOLES = "115200;ttymxc2", when I change this to SERIAL_CONSOLES ?= "115200;ttymxc2" my changes are being applied.

This off course is not ideal since I then still don’t have all changes in my own layer.

Is there a way I can solve this?

Kind regards,

Chris


--
Mike Looijmans


chris yocto
 

Thank you for you reply.

I actually do want to replace SERIAL_CONSOLES because I am using the original for another purpose ( not a console).


Khem Raj
 

On Tue, Jul 12, 2022 at 12:41 PM chris yocto <chrisyocto2022@...> wrote:

Hi,



I’m trying to customize the SERIAL_CONSOLES variable. In another thread I read this can be done by adding a machine-extra.conf file too my custom layer. So I added “ SERIAL_CONSOLES = "115200;ttymxc0" ” to my machine-extra.conf, but when I bitbake my custom image, no changes are found.

In the conf file from the bsp for the board I’m using I found “SERIAL_CONSOLES = "115200;ttymxc2", when I change this to SERIAL_CONSOLES ?= "115200;ttymxc2" my changes are being applied.

This off course is not ideal since I then still don’t have all changes in my own layer.

Is there a way I can solve this?
there can be multiple entries in SERIAL_CONSOLES so you might try
adding instead of replacing

SERIAL_CONSOLES += "115200;ttymxc0"

might work



Kind regards,



Chris




chris yocto
 

Hi,

 

I’m trying to customize the SERIAL_CONSOLES variable. In another thread I read this can be done by adding a machine-extra.conf file too my custom layer. So I added “ SERIAL_CONSOLES = "115200;ttymxc0" ” to my machine-extra.conf, but when I  bitbake my custom image, no changes are found.

In the conf file from the bsp for the board I’m using I found “SERIAL_CONSOLES = "115200;ttymxc2", when I change this to SERIAL_CONSOLES ?= "115200;ttymxc2" my changes are being applied.

This off course is not ideal since I then still don’t have all changes in my own layer.  

Is there a way I can solve this?

 

Kind regards,

 

Chris