Specified SDKMACHINE value is not valid


jchludzinski
 

I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to host on the same RP4. Admittedly, a not practical platform for this purpose but it should work.

I'm trying to target the ARM ISA for the image using yocto-3.4.2. I've tried simply using the default setting and end up with:
 
ERROR:  OE-core's config sanity checker detected a potential misconfiguration.
    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
    Following is the list of potential problems / advisories:
 
    Specified SDKMACHINE value is not valid
 

I've tried editing ./conf/local.conf:

MACHINE ?= "qemuarm64"

#MACHINE ??= "qemux86-64"

But this accomplishes nothing. Needless to say, I'm a yacto/OE newbie, so any suggestions would be greatly appreciated.

---John


Khem Raj
 



On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via lists.yoctoproject.org <jchludzinski=vivaldi.net@...> wrote:
I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to host on the same RP4. Admittedly, a not practical platform for this purpose but it should work.

I'm trying to target the ARM ISA for the image using yocto-3.4.2. I've tried simply using the default setting and end up with:
 
ERROR:  OE-core's config sanity checker detected a potential misconfiguration.
    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
    Following is the list of potential problems / advisories:
 
    Specified SDKMACHINE value is not valid
 

I've tried editing ./conf/local.conf:

MACHINE ?= "qemuarm64"

#MACHINE ??= "qemux86-64"


It’s complaining about SDKMACHINE setting which is a separate variable, can you check your local.conf if it’s set to something 

But this accomplishes nothing. Needless to say, I'm a yacto/OE newbie, so any suggestions would be greatly appreciated.

---John





jchludzinski
 

There's this:
#SDKMACHINE ?= "i686"
 
---John


On 2022-04-01 16:22, Khem Raj wrote:
On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via lists.yoctoproject.org
[1] <jchludzinski=vivaldi.net@...> wrote:

I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to
host on the same RP4. Admittedly, a not practical platform for this
purpose but it should work.

I'm trying to target the ARM ISA for the image using yocto-3.4.2.
I've tried simply using the default setting and end up with:

_ERROR:  OE-core's config sanity checker detected a potential
misconfiguration._
_    Either fix the cause of this error or at your own risk disable
the checker (see sanity.conf)._
_    Following is the list of potential problems / advisories:_
_ _
_    Specified SDKMACHINE value is not valid_

I've tried editing ./conf/local.conf:

MACHINE ?= "qemuarm64"

#MACHINE ??= "qemux86-64"

It’s complaining about SDKMACHINE setting which is a separate
variable, can you check your local.conf if it’s set to something

But this accomplishes nothing. Needless to say, I'm a yacto/OE
newbie, so any suggestions would be greatly appreciated.

---John
 

Links:
------
[1] http://lists.yoctoproject.org


jchludzinski
 

But obviously commented out.

On 2022-04-01 16:43, jchludzinski via lists.yoctoproject.org wrote:
There's this:
#SDKMACHINE ?= "i686"
---John
On 2022-04-01 16:22, Khem Raj wrote:

On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via
lists.yoctoproject.org
[1 [1]] <jchludzinski=vivaldi.net@...> wrote:

I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to
host on the same RP4. Admittedly, a not practical platform for
this
purpose but it should work.
I'm trying to target the ARM ISA for the image using yocto-3.4.2.
I've tried simply using the default setting and end up with:
_ERROR: OE-core's config sanity checker detected a potential
misconfiguration._
_ Either fix the cause of this error or at your own risk
disable
the checker (see sanity.conf)._
_ Following is the list of potential problems / advisories:_
_ _
_ Specified SDKMACHINE value is not valid_
I've tried editing ./conf/local.conf:
MACHINE ?= "qemuarm64"
#MACHINE ??= "qemux86-64"
It's complaining about SDKMACHINE setting which is a separate
variable, can you check your local.conf if it's set to something

But this accomplishes nothing. Needless to say, I'm a yacto/OE
newbie, so any suggestions would be greatly appreciated.
---John
Links:
------
[1] http://lists.yoctoproject.org
Links:
------
[1] http://lists.yoctoproject.org


Khem Raj
 

On Fri, Apr 1, 2022 at 2:02 PM jchludzinski <jchludzinski@...> wrote:

But obviously commented out.

On 2022-04-01 16:43, jchludzinski via lists.yoctoproject.org wrote:
There's this:
#SDKMACHINE ?= "i686"
OK it should be ok then. Can you describe your steps to setup the system?
maybe there is some caveat


---John

On 2022-04-01 16:22, Khem Raj wrote:

On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via
lists.yoctoproject.org
[1 [1]] <jchludzinski=vivaldi.net@...> wrote:

I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to
host on the same RP4. Admittedly, a not practical platform for
this
purpose but it should work.

I'm trying to target the ARM ISA for the image using yocto-3.4.2.
I've tried simply using the default setting and end up with:

_ERROR: OE-core's config sanity checker detected a potential
misconfiguration._
_ Either fix the cause of this error or at your own risk
disable
the checker (see sanity.conf)._
_ Following is the list of potential problems / advisories:_
_ _
_ Specified SDKMACHINE value is not valid_

I've tried editing ./conf/local.conf:

MACHINE ?= "qemuarm64"

#MACHINE ??= "qemux86-64"
It's complaining about SDKMACHINE setting which is a separate
variable, can you check your local.conf if it's set to something

But this accomplishes nothing. Needless to say, I'm a yacto/OE
newbie, so any suggestions would be greatly appreciated.

---John
Links:
------
[1] http://lists.yoctoproject.org

Links:
------
[1] http://lists.yoctoproject.org


jchludzinski
 

$ git clone git://git.yoctoproject.org/poky.git
$ cd ./poky
$ git checkout yocto-3.4.2
$ cd ..
$ source ./poky/oe-init-build-env
$ cd ./build
$ time bitbake core-image-minimal
...
ERROR:  OE-core's config sanity checker detected a potential misconfiguration.
    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
    Following is the list of potential problems / advisories:
 
    Specified SDKMACHINE value is not valid
 
 
Summary: There was 1 WARNING message shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit code.
 
________________________________________________________
Executed in    3.92 secs    fish           external
   usr time    1.07 secs    9.77 millis    1.06 secs
   sys time    0.18 secs    2.96 millis    0.17 secs


 

On 2022-04-01 18:09, Khem Raj wrote:
On Fri, Apr 1, 2022 at 2:02 PM jchludzinski <jchludzinski@...> wrote:

But obviously commented out.

On 2022-04-01 16:43, jchludzinski via lists.yoctoproject.org wrote:
There's this:
#SDKMACHINE ?= "i686"

OK it should be ok then. Can you describe your steps to setup the system?
maybe there is some caveat


---John

On 2022-04-01 16:22, Khem Raj wrote:

On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via
lists.yoctoproject.org
[1 [1]] <jchludzinski=vivaldi.net@...> wrote:

I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to
host on the same RP4. Admittedly, a not practical platform for
this
purpose but it should work.

I'm trying to target the ARM ISA for the image using yocto-3.4.2.
I've tried simply using the default setting and end up with:

_ERROR:  OE-core's config sanity checker detected a potential
misconfiguration._
_    Either fix the cause of this error or at your own risk
disable
the checker (see sanity.conf)._
_    Following is the list of potential problems / advisories:_
_ _
_    Specified SDKMACHINE value is not valid_

I've tried editing ./conf/local.conf:

MACHINE ?= "qemuarm64"

#MACHINE ??= "qemux86-64"

It's complaining about SDKMACHINE setting which is a separate
variable, can you check your local.conf if it's set to something

But this accomplishes nothing. Needless to say, I'm a yacto/OE
newbie, so any suggestions would be greatly appreciated.

---John

Links:
------
[1] http://lists.yoctoproject.org


Links:
------
[1] http://lists.yoctoproject.org





Khem Raj
 

On Sat, Apr 2, 2022 at 1:47 AM jchludzinski <jchludzinski@...> wrote:

$ git clone git://git.yoctoproject.org/poky.git
$ cd ./poky
$ git checkout yocto-3.4.2
$ cd ..
$ source ./poky/oe-init-build-env
$ cd ./build
$ time bitbake core-image-minimal
...
ERROR: OE-core's config sanity checker detected a potential misconfiguration.
Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
Following is the list of potential problems / advisories:

Specified SDKMACHINE value is not valid


Summary: There was 1 WARNING message shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

________________________________________________________
Executed in 3.92 secs fish external
usr time 1.07 secs 9.77 millis 1.06 secs
sys time 0.18 secs 2.96 millis 0.17 secs



On 2022-04-01 18:09, Khem Raj wrote:

On Fri, Apr 1, 2022 at 2:02 PM jchludzinski <jchludzinski@...> wrote:


But obviously commented out.

On 2022-04-01 16:43, jchludzinski via lists.yoctoproject.org wrote:

There's this:
#SDKMACHINE ?= "i686"


OK it should be ok then. Can you describe your steps to setup the system?
maybe there is some caveat


---John

On 2022-04-01 16:22, Khem Raj wrote:

On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via
lists.yoctoproject.org
[1 [1]] <jchludzinski=vivaldi.net@...> wrote:

I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to
host on the same RP4. Admittedly, a not practical platform for
this
purpose but it should work.

I'm trying to target the ARM ISA for the image using yocto-3.4.2.
I've tried simply using the default setting and end up with:

_ERROR: OE-core's config sanity checker detected a potential
misconfiguration._
_ Either fix the cause of this error or at your own risk
disable
the checker (see sanity.conf)._
_ Following is the list of potential problems / advisories:_
_ _
_ Specified SDKMACHINE value is not valid_

I've tried editing ./conf/local.conf:

MACHINE ?= "qemuarm64"

#MACHINE ??= "qemux86-64"


It's complaining about SDKMACHINE setting which is a separate
variable, can you check your local.conf if it's set to something

But this accomplishes nothing. Needless to say, I'm a yacto/OE
newbie, so any suggestions would be greatly appreciated.
are you on a x86_64 host? Secondly try to uncomment SDKMACHINE setting
in local.conf
and see if it helps. Also check if your default shell is bash or dash.


---John


Links:
------
[1] http://lists.yoctoproject.org



Links:
------
[1] http://lists.yoctoproject.org





jchludzinski
 

I’m actually trying this on an RP4 running Raspbian.

On 2022-04-02 12:15, Khem Raj wrote:
On Sat, Apr 2, 2022 at 1:47 AM jchludzinski <jchludzinski@...> wrote:
$ git clone git://git.yoctoproject.org/poky.git
$ cd ./poky
$ git checkout yocto-3.4.2
$ cd ..
$ source ./poky/oe-init-build-env
$ cd ./build
$ time bitbake core-image-minimal
...
ERROR: OE-core's config sanity checker detected a potential misconfiguration.
Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
Following is the list of potential problems / advisories:
Specified SDKMACHINE value is not valid
Summary: There was 1 WARNING message shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit code.
________________________________________________________
Executed in 3.92 secs fish external
usr time 1.07 secs 9.77 millis 1.06 secs
sys time 0.18 secs 2.96 millis 0.17 secs
On 2022-04-01 18:09, Khem Raj wrote:
On Fri, Apr 1, 2022 at 2:02 PM jchludzinski <jchludzinski@...> wrote:
But obviously commented out.
On 2022-04-01 16:43, jchludzinski via lists.yoctoproject.org wrote:
There's this:
#SDKMACHINE ?= "i686"
OK it should be ok then. Can you describe your steps to setup the system?
maybe there is some caveat
---John
On 2022-04-01 16:22, Khem Raj wrote:
On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via
lists.yoctoproject.org
[1 [1]] <jchludzinski=vivaldi.net@...> wrote:
I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to
host on the same RP4. Admittedly, a not practical platform for
this
purpose but it should work.
I'm trying to target the ARM ISA for the image using yocto-3.4.2.
I've tried simply using the default setting and end up with:
_ERROR: OE-core's config sanity checker detected a potential
misconfiguration._
_ Either fix the cause of this error or at your own risk
disable
the checker (see sanity.conf)._
_ Following is the list of potential problems / advisories:_
_ _
_ Specified SDKMACHINE value is not valid_
I've tried editing ./conf/local.conf:
MACHINE ?= "qemuarm64"
#MACHINE ??= "qemux86-64"
It's complaining about SDKMACHINE setting which is a separate
variable, can you check your local.conf if it's set to something
But this accomplishes nothing. Needless to say, I'm a yacto/OE
newbie, so any suggestions would be greatly appreciated.
are you on a x86_64 host? Secondly try to uncomment SDKMACHINE setting
in local.conf
and see if it helps. Also check if your default shell is bash or dash.

---John
Links:
------
[1] http://lists.yoctoproject.org
Links:
------
[1] http://lists.yoctoproject.org
--
NULL


Khem Raj
 

On Sat, Apr 2, 2022 at 9:37 AM jchludzinski <jchludzinski@...> wrote:

I’m actually trying this on an RP4 running Raspbian.
Oh I see. we do support aarch64 as build host, so if you are trying
64bit OS on rpi then it should work
although, rpi4 may not have enough muscle to build, perhaps using SSD
with rpi4 might help a bit

So find out if rpi4 is running in 64bit mode if not then building on
armv7 might have issues.

in anycase try setting SDKMACHINE = "i686" this should get you past
this particular error, there might be more after it.

Fixed when x11 is not in DISTRO_FEATURES:
$ bitbake wxwidgets
ERROR: Nothing PROVIDES 'wxwidgets'
wxwidgets was skipped: missing required distro feature 'x11' (not in
DISTRO_FEATURES)


On 2022-04-02 12:15, Khem Raj wrote:
On Sat, Apr 2, 2022 at 1:47 AM jchludzinski <jchludzinski@...>
wrote:

$ git clone git://git.yoctoproject.org/poky.git
$ cd ./poky
$ git checkout yocto-3.4.2
$ cd ..
$ source ./poky/oe-init-build-env
$ cd ./build
$ time bitbake core-image-minimal
...
ERROR: OE-core's config sanity checker detected a potential
misconfiguration.
Either fix the cause of this error or at your own risk disable the
checker (see sanity.conf).
Following is the list of potential problems / advisories:

Specified SDKMACHINE value is not valid


Summary: There was 1 WARNING message shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit
code.

________________________________________________________
Executed in 3.92 secs fish external
usr time 1.07 secs 9.77 millis 1.06 secs
sys time 0.18 secs 2.96 millis 0.17 secs



On 2022-04-01 18:09, Khem Raj wrote:

On Fri, Apr 1, 2022 at 2:02 PM jchludzinski <jchludzinski@...>
wrote:


But obviously commented out.

On 2022-04-01 16:43, jchludzinski via lists.yoctoproject.org wrote:

There's this:
#SDKMACHINE ?= "i686"


OK it should be ok then. Can you describe your steps to setup the
system?
maybe there is some caveat


---John

On 2022-04-01 16:22, Khem Raj wrote:

On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via
lists.yoctoproject.org
[1 [1]] <jchludzinski=vivaldi.net@...> wrote:

I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to
host on the same RP4. Admittedly, a not practical platform for
this
purpose but it should work.

I'm trying to target the ARM ISA for the image using yocto-3.4.2.
I've tried simply using the default setting and end up with:

_ERROR: OE-core's config sanity checker detected a potential
misconfiguration._
_ Either fix the cause of this error or at your own risk
disable
the checker (see sanity.conf)._
_ Following is the list of potential problems / advisories:_
_ _
_ Specified SDKMACHINE value is not valid_

I've tried editing ./conf/local.conf:

MACHINE ?= "qemuarm64"

#MACHINE ??= "qemux86-64"


It's complaining about SDKMACHINE setting which is a separate
variable, can you check your local.conf if it's set to something

But this accomplishes nothing. Needless to say, I'm a yacto/OE
newbie, so any suggestions would be greatly appreciated.
are you on a x86_64 host? Secondly try to uncomment SDKMACHINE setting
in local.conf
and see if it helps. Also check if your default shell is bash or dash.


---John


Links:
------
[1] http://lists.yoctoproject.org



Links:
------
[1] http://lists.yoctoproject.org




--
NULL


Ross Burton <ross@...>
 

Is Raspian 32- or 64-bit? We don't suppose 32-bit arm SDKs.

As Khem said, set SDKMACHINE to i686 explicitly to avoid this. Note
that compiling on a RPi4 is *very slow*.

Ross

On Sat, 2 Apr 2022 at 17:37, jchludzinski via lists.yoctoproject.org
<jchludzinski=vivaldi.net@...> wrote:

I’m actually trying this on an RP4 running Raspbian.

On 2022-04-02 12:15, Khem Raj wrote:
On Sat, Apr 2, 2022 at 1:47 AM jchludzinski <jchludzinski@...>
wrote:

$ git clone git://git.yoctoproject.org/poky.git
$ cd ./poky
$ git checkout yocto-3.4.2
$ cd ..
$ source ./poky/oe-init-build-env
$ cd ./build
$ time bitbake core-image-minimal
...
ERROR: OE-core's config sanity checker detected a potential
misconfiguration.
Either fix the cause of this error or at your own risk disable the
checker (see sanity.conf).
Following is the list of potential problems / advisories:

Specified SDKMACHINE value is not valid


Summary: There was 1 WARNING message shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit
code.

________________________________________________________
Executed in 3.92 secs fish external
usr time 1.07 secs 9.77 millis 1.06 secs
sys time 0.18 secs 2.96 millis 0.17 secs



On 2022-04-01 18:09, Khem Raj wrote:

On Fri, Apr 1, 2022 at 2:02 PM jchludzinski <jchludzinski@...>
wrote:


But obviously commented out.

On 2022-04-01 16:43, jchludzinski via lists.yoctoproject.org wrote:

There's this:
#SDKMACHINE ?= "i686"


OK it should be ok then. Can you describe your steps to setup the
system?
maybe there is some caveat


---John

On 2022-04-01 16:22, Khem Raj wrote:

On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via
lists.yoctoproject.org
[1 [1]] <jchludzinski=vivaldi.net@...> wrote:

I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to
host on the same RP4. Admittedly, a not practical platform for
this
purpose but it should work.

I'm trying to target the ARM ISA for the image using yocto-3.4.2.
I've tried simply using the default setting and end up with:

_ERROR: OE-core's config sanity checker detected a potential
misconfiguration._
_ Either fix the cause of this error or at your own risk
disable
the checker (see sanity.conf)._
_ Following is the list of potential problems / advisories:_
_ _
_ Specified SDKMACHINE value is not valid_

I've tried editing ./conf/local.conf:

MACHINE ?= "qemuarm64"

#MACHINE ??= "qemux86-64"


It's complaining about SDKMACHINE setting which is a separate
variable, can you check your local.conf if it's set to something

But this accomplishes nothing. Needless to say, I'm a yacto/OE
newbie, so any suggestions would be greatly appreciated.
are you on a x86_64 host? Secondly try to uncomment SDKMACHINE setting
in local.conf
and see if it helps. Also check if your default shell is bash or dash.


---John


Links:
------
[1] http://lists.yoctoproject.org



Links:
------
[1] http://lists.yoctoproject.org




--
NULL