Query regarding yocto build


Ross Burton <ross@...>
 

Looks like the libraries are unversioned. This is pretty bad practise
but https://docs.yoctoproject.org/dev-manual/common-tasks.html#working-with-pre-built-libraries
should help.

The best solution is to get OMADM to version the libraries, instead of
working around their unversioned libraries in the recipe.

Ross


Rudolf J Streif
 

Hello,

Topposting since the problem is in the screenshot.

The issue is the naming of the shared object. Linux convention is that a shared object contains the version number e.g. log_wrapper.so.1 and log_wrapper.so is a link to that file.

In you make file either change the install target or use -soname=log_wrapper.so.1 when invoking gcc to create the shared object.

:rjs

On 3/15/22 12:52 AM, Nupur Purohit wrote:
Hi,

Please find the below error snapshot.

I am trying to integrate OMADM (Open mobile alliance device management) on the top of yocto 3.4.2 (honister) poky. And facing the following issue with bitbake log-wrapper ( one of the APIs I'm trying to integrate).

Please provide assistance to resolve the error.

Thanks and regards,
Nupur



-- 
Rudolf J Streif
CEO/CTO ibeeto
+1.855.442.3386 x700


nupur100299@...
 

Hi,

Please find the below error snapshot.

I am trying to integrate OMADM (Open mobile alliance device management) on the top of yocto 3.4.2 (honister) poky. And facing the following issue with bitbake log-wrapper ( one of the APIs I'm trying to integrate).

Please provide assistance to resolve the error.

Thanks and regards,
Nupur