Custom Image Type


Rudolf J Streif
 

I ran into a problem with a custom image type class. I called the class image_types_ota.bbclass.

When I try to use it I am getting these error messages for two predefined image recipes (but only for these two, for any other image recipe it is fine):

ERROR: /develop/projects/tcu/build/../poky/meta/recipes-rt/images/core-image-rt-sdk.bb: No IMAGE_CMD defined for IMAGE_FSTYPES entry 'ota' - possibly invalid type name or missing support class
ERROR: /develop/projects/tcu/build/../meta-openembedded/meta-networking/recipes-core/images/meta-networking-image-base.bb: No IMAGE_CMD defined for IMAGE_FSTYPES entry 'ota' - possibly invalid type name or missing support class
ERROR: Failed to parse recipe: /develop/projects/tcu/build/../poky/meta/recipes-rt/images/core-image-rt-sdk.bb

I have no idea what in these two image recipes could trigger this error message.

Thanks,
Rudi


Khem Raj
 

On Mon, Feb 28, 2022 at 8:32 PM Rudolf J Streif
<rudolf.streif@...> wrote:

I ran into a problem with a custom image type class. I called the class
image_types_ota.bbclass.

When I try to use it I am getting these error messages for two
predefined image recipes (but only for these two, for any other image
recipe it is fine):

ERROR:
/develop/projects/tcu/build/../poky/meta/recipes-rt/images/core-image-rt-sdk.bb:
No IMAGE_CMD defined for IMAGE_FSTYPES entry 'ota' - possibly invalid
type name or missing support class
ERROR:
/develop/projects/tcu/build/../meta-openembedded/meta-networking/recipes-core/images/meta-networking-image-base.bb:
No IMAGE_CMD defined for IMAGE_FSTYPES entry 'ota' - possibly invalid
type name or missing support class
ERROR: Failed to parse recipe:
/develop/projects/tcu/build/../poky/meta/recipes-rt/images/core-image-rt-sdk.bb

I have no idea what in these two image recipes could trigger this error
message.
hard to tell without knowing how ota class is being plugged in or what
its content is.
Do you define IMAGE_FSTYPES:ota ... somewhere ?

Thanks,
Rudi




Rudolf J Streif
 

Thanks, Khem.

On 2/28/22 8:54 PM, Khem Raj wrote:
On Mon, Feb 28, 2022 at 8:32 PM Rudolf J Streif
<rudolf.streif@...> wrote:
I ran into a problem with a custom image type class. I called the class
image_types_ota.bbclass.

When I try to use it I am getting these error messages for two
predefined image recipes (but only for these two, for any other image
recipe it is fine):

ERROR:
/develop/projects/tcu/build/../poky/meta/recipes-rt/images/core-image-rt-sdk.bb:
No IMAGE_CMD defined for IMAGE_FSTYPES entry 'ota' - possibly invalid
type name or missing support class
ERROR:
/develop/projects/tcu/build/../meta-openembedded/meta-networking/recipes-core/images/meta-networking-image-base.bb:
No IMAGE_CMD defined for IMAGE_FSTYPES entry 'ota' - possibly invalid
type name or missing support class
ERROR: Failed to parse recipe:
/develop/projects/tcu/build/../poky/meta/recipes-rt/images/core-image-rt-sdk.bb

I have no idea what in these two image recipes could trigger this error
message.
hard to tell without knowing how ota class is being plugged in or what
its content is.
Do you define IMAGE_FSTYPES:ota ... somewhere ?
The image class defines IMAGE_CMD. There is not much to it for now:

OTA_ROOTFS_MD5 ?= "rootfs.md5"

IMAGE_CMD:ota () {
    build_ota="${WORKDIR}/build-ota"

    # rootfs
    md5sum ${IMAGE_ROOTFS} > ${build_ota}/OTA_ROOTFS_MD5
}

What I don't see is why these two are the only image recipes this is occurring with. All the other image recipes do not throw a parser error.

Thanks,
Rudi


--
Rudolf J Streif
CEO/CTO ibeeto
+1.855.442.3386 x700